Update 41 is now available for testing on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 26:
• PC/Mac: No maintenance – February 26

"A Book and its Cover" is utterly broken for me. What else can I try?

dk_dunkirk
dk_dunkirk
✭✭✭
I'm trying to do the achievement, but I've never once started the quest, even though I've finished all the quests in Summerset. I've traveled around the island countless times, and fast traveled to the Russafield wayshrine about 100 times. I run into the nobles from time to time, but I never start the quest. I have done "Surreptitiously Shadowed" already in Murkmire. I ran around the spawn points over the course of a couple hours, and finished that as expected. But after several days, I can't pop the first encounter on Summerset. Something seems stuck. Is it *because* I already finished with Choixth in Murkmire? This is taking all the fun out of the game for me. It's one thing to take a long time to do something. It another thing to just be stuck.
Edited by ZOS_Hadeostry on February 6, 2024 4:08AM
  • ZOS_Hadeostry
    Greetings,

    After further review we have decided to move this thread to a category we think is more appropriate for this topic, as it's asking the community for assistance.

    Thank you for your understanding
    Staff Post
Sign In or Register to comment.