Maintenance for the week of April 3:
• PC/Mac: No NA megaserver maintenance – April 3
• PC/Mac: EU megaserver for maintenance – April 3, 8:00PM EDT (April 4, 00:00 UTC) – April 4, 10:00AM EDT (14:00 UTC)

Eso is partially unable to save player data

So I have been experiencing this very annoying bug for at least 6-9 months now. The game fails to save some of my data, especially my searchterms & -settings at the guildtraders. Everytime I restart the game my list of previously searched items is completely wiped. This hinderes me from using the traders since I usually search for about 10 different items every day.

I already talked to customer support, but they didnt have a solution for me. Their only advice was to delete my local savefiles, which only resulted in a now completely empty trader-list (before that my searchterms showed the same age-old terms I used to use, every time I restarted the game. After I got rid of the savefiles the list is now empty every time), some of my battle-options got removed and the auto-crafting-options at the crafting tables were wiped.

I've re-done my battle-options (which are working ever since) but the trader-searchterms and the favoured settings at the craftingtables don't apply after I restart the game.

I narrowed the error down a bit:
The fact that it did load my age-old searchterms & crafting preferences beforehand shows me that loading gamedata doesn't seem to be the problem here. But saving my data when I close the game is indeed a problem.
I'm playing on the PS5 and I've tried the disc-version and the digital version. I also tried disc-and digital versions on my old PS4 and also deleted & reinstalled everything but the bug is still present on all versions/systems.
I also know from other players that their search-history is not saved too, but also from players where everything works fine for them.

This bug really annoys me at this point. I cant use the traders as I'd like to, which does negatively influence my trading- & shopping-experience.
  • fizl101
    Yes, outstanding issue for a while now - it has been going since High Isle, and intermittently before then. Not only the filter preferences etc, but I also have to clear my save file when the new tales of tribute season starts to be able to play it.
    Soupy twist
Sign In or Register to comment.