Update 43 is now available for testing on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of July 22:
• PC/Mac: NA and EU megaservers for patch maintenance – July 22, 4:00AM EDT (8:00 UTC) - 9:00AM EDT (13:00 UTC)
• Xbox: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) - 12:00PM EDT (16:00 UTC)
• PlayStation®: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

WritWorthy

Sly80
Sly80
✭✭✭
This was working okay yesterday. Today it says LibLazyCrafter is out of date, but it is the latest version. Any clues?
  • Sly80
    Sly80
    ✭✭✭
    Ah, I see there are similar problems with other addons...
    Options
  • Sly80
    Sly80
    ✭✭✭
    And today it is working :| Seemingly random bug
    Options
  • M0R_Gaming
    M0R_Gaming
    ✭✭✭
    You can pretty much ignore the ingame notice saying that addons are out of date, unless they are not working as intended.

    ESO has a current "API Version", which as of right now is 101036. An addon is able to tell the game which API version it was made for, and if what the addon says doesn't match the current API version, the game puts an "out of date" marker ingame on the addon list.
    All that this out-of-date marker means is that the addon was made/updated for an older version of ESO, so it may or may not work with the latest update. This is separate from the addon's own updates, as that is handled through stuff like esoui/minion.

    For example, I can make a simple addon when ESO was on API 101035, and the game wouldn't show that the addon was out of date, but if the game releases a new update, the API goes up to 101036, thus marking the addon as 'potentially out of date'. If my addon was really simple, I may not need to go and change that API version presented by the addon, so the game will keep on saying that the addon is potentially out of date, even though it works fine.
    Edited by M0R_Gaming on November 13, 2022 10:51PM
    • PC/NA - PvP/PvE AD Magsorc main
    • Former Emp, All HMs but DSR
    My addons
    Options
  • Necrotech_Master
    Necrotech_Master
    ✭✭✭✭✭
    ✭✭✭✭✭
    yeah, i usually ignore out of date addon warning unless the addon is actually producing UI errors (i have a few addons that are still functional that havent been updated in 4-5 years lol)
    plays PC/NA
    handle @Necrotech_Master
    active player since april 2014
    Options
  • Sly80
    Sly80
    ✭✭✭
    Thanks for the advice, which is good to know. In this case, however the add-on was in red and not functioning, and the library was in red as well. It worked the day before and the day after, so some random glitch I suspect, from the last update.
    Options
  • Necrotech_Master
    Necrotech_Master
    ✭✭✭✭✭
    ✭✭✭✭✭
    if the addon is red text, then that means it likely is not enabled at all because it is missing 1 or more dependencies (likely the same with the library, as libraries themselves can also have dependencies)

    the little arrow on the left of the name expands the information down so you can see which libraries it is using and other information about the addon usually
    plays PC/NA
    handle @Necrotech_Master
    active player since april 2014
    Options
  • Sly80
    Sly80
    ✭✭✭
    if the addon is red text, then that means it likely is not enabled at all because it is missing 1 or more dependencies (likely the same with the library, as libraries themselves can also have dependencies)

    the little arrow on the left of the name expands the information down so you can see which libraries it is using and other information about the addon usually

    Yes. The dependency was LibLazyCrafter.
    Options
Sign In or Register to comment.