Maintenance for the week of January 17:
• [COMPLETE] PlayStation®: NA megaserver for maintenance – January 19, 2:00AM EST (7:00 UTC) – 12:00PM EST (17:00 UTC)
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• [COMPLETE] PlayStation®: EU megaserver for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• ESO Store and Account System for maintenance – January 20, 8:00AM EST (13:00 UTC) – 3:00PM EST (20:00 UTC)

Official Discussion Thread for "Deadlands and Update 32 Special"

ZOS_Kevin
ZOS_Kevin
admin
eboyps563qni.jpg

This is the official discussion thread for "Deadlands and Update 32 Special"

It’s dangerous to go into Oblivion alone, so take these new guides for the Deadlands DLC and Update 32 from the ESO community!
Forum Manager for ZeniMax Online Studio and Elder Scrolls Online
Staff Post
  • houndandhorseb16_ESO
    First off, Love this area so far, love the changes and love the Armorer. Here is the but, since the Nov 4th hot patch to fix the CP issue my armor station and CP points don't get along. I can save my build, I can equip my saved build. If I check the CP points after this to make sure all is actually set. They are all still reset to none actually used and my slots are empty.
    If I don't use the station, the game is actually saving my assigned CP points.
    Once again go to station and it resets them all to none assigned and I have to start from scratch. Can this please be fixed? It was working great prior to this hot patch.
Sign In or Register to comment.