The Firesong DLC and Update 36 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of October 3:
• [COMPLETE] PC/Mac: NA and EU megaservers for patch maintenance – October 3, 4:00AM EDT (8:00 UTC) - 9:00AM EDT (13:00 UTC)
• Xbox: NA and EU megaservers for patch maintenance – October 5, 6:00AM EDT (10:00 UTC) - 11:00AM EDT (15:00 UTC)
• PlayStation®: NA and EU megaservers for patch maintenance – October 5, 6:00AM EDT (10:00 UTC) - 11:00AM EDT (15:00 UTC)

Gamepad Issue

Alienoutlaw
Alienoutlaw
✭✭✭✭✭
✭✭
gamepad is enabled but not working after patch
  • Alienoutlaw
    Alienoutlaw
    ✭✭✭✭✭
    ✭✭
    @ZOS_GinaBruno
    @ZOS_BillE
    any idea whats wrong here? i have dissabled all ADDONS, run a game repair and still no Gamepad function
  • IsJustaGhost
    For me, it's defaulting to keyboard controls on every ui change or pressing a button. Gamepad mode is set to "On", not "Auto".

    Pressing escape in inventory changes controls to keyboard, not exit inventory.
    GPmodeControlsBug.gif

    I even rebound the gamepad Ui controls to gamepad first.
    image.png
  • ZOS_GinaBruno
    ZOS_GinaBruno
    Community Manager
    Hi both, could you please let us know what type of controller you are using? Thanks!
    Gina Bruno
    Senior Community Manager
    Dev Tracker | Service Alerts | ESO Twitter | My Twitter
    Staff Post
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    I have an elite series 2 controller, and while gamepad ui IS working *knock on wood* the labels keep swapping to keyboard and back after every button press/menu/movement


    Also the UI isn't updating - I supposedly dismissed a notification *(that was in keyboard UI, but contoller A worked) YET... I still have a notification. But notifications isn't in my menu....

    Dw3Rj2Y.png
    Edited by CaffeinatedMayhem on November 1, 2021 6:09PM
  • PurpleScroll
    PurpleScroll
    ✭✭✭✭
    Oddly I am not getting this bug, using an 8bitdo SN30 Pro+. The only thing I see 'wrong' is that the key icons switch between keyboard and gamepad depending on which one I am using, even with Gamepad mode set to 'On' and not 'Auto'. However, I can just keep using the gamepad with no issue.
  • IsJustaGhost
    XBOX one wired usb

    The issue I am seeing is that it defaults to keyboard UI controls when Gamepad mode is set to ON.
    The UI updates to gamepad controls only when a button is pressed on the gamepad.

    Escape really should exit to HUD, not switch back to keyboard mode, then exit to HUD on a second press. I understand switching UI controls to keyboard layout if a keyboard related button is pressed, but escape should be escape.

    If Gamepad mode is set to ON, then the Ui controls should always default to gamepad layout.
  • phaneub17_ESO
    phaneub17_ESO
    ✭✭✭✭✭
    ✭✭✭✭✭
    Also mention if you're using Steam (Big Picture Mode) or Stadia. The switching of keys is kind of neat actually, if its not intentional I like it to be a feature. It's more seamless compared to other games that tend to have a hitch stutter when switching.
  • Genesiis
    Genesiis
    Soul Shriven
    Same problem here, the gamepad UI stays the same, but If I touch my keyboard it switches my skill bar from UP on Dpad, X, Y, B, LB, RB and LB+RB to Q, 1, 2, 3, 4, 5 and 6. The reverse happens when I touch my gamepad. I have no add-ons and my UI is set to default.
    In The Beginning...
  • IsJustaGhost
    Genesiis wrote: »
    Same problem here, the gamepad UI stays the same, but If I touch my keyboard it switches my skill bar from UP on Dpad, X, Y, B, LB, RB and LB+RB to Q, 1, 2, 3, 4, 5 and 6. The reverse happens when I touch my gamepad. I have no add-ons and my UI is set to default.

    This is how it is meant to be. However, the real issues here are, escape does not exit UI if in gamepad mode, and if Gamepad mode is set to ON, using a keyboard keybind to open a UI opens it with keyboard keybinds active, making an extra step to to actually do something in the UI.

    Example:
    Press [ I ] on keyboard to open inventory, press ( B ) does not exit, but changes to gamepad controls, then press ( B ) again will exit.

    This needs to be change to where if Gamepad mode is set to ON, then pressing any keyboard keybind that is set to open a gamepad UI needs to open with gamepad keybinds active by default.
  • IsJustaGhost
    I'm trying to encourage this to get fixed. If not I'll look at making an addon that will do it.
  • WuffyCerulei
    WuffyCerulei
    ✭✭✭✭✭
    ✭✭✭
    I won’t lie, I complained about how janky the new Gamepad UI stuff was on the PTS, but it fell on deaf ears. Hopefully they’ll actually listen this time.
    For the love of Kyne, buff sorc.

    PC NA
    CP 2000+
    Star-Sïnger - Khajiit Magicka Sorc - EP Grand Warlord - Flawless Conqueror
    vMA/vBRP/vDSA no death/vHel Ra HM/vAA HM/vSO HM/vMoL HM/vHoF HM/vAS +2/vCR+3/vSS HMs/vKA HM/vVH/vRG Oax HM/vDSR
    Falls-With-Stars - Argonian Magicka Templar - Former Empress
    Dragon-in-Shadows - Argonian Nightblade Tank - Shadow Breaker
    Eossos - Khajiit Magicka Templar Healer
    Death-Singer - Argonian Magicka Nightblade
    Dark-Star - Khajiit Magicka Dragonknight
    Ice-Dancer - Khajiit Magicka Warden
    Tsalli-ko - Khajiit Stamina Sorcerer
    The-Gold-Experience - Khajiit Magicka Necromancer
    Khiiral - Dunmer Magicka Dragonknight
  • Alienoutlaw
    Alienoutlaw
    ✭✭✭✭✭
    ✭✭
    Hi both, could you please let us know what type of controller you are using? Thanks!

    xbox elite 2 wired updated drivers also
  • mlbeaver_ESO
    mlbeaver_ESO
    ✭✭
    Yes, I'm seeing the same issue of the auto switching being on in spite of the setting not being enabled... using an XBox 360 wireless controller...
  • Baertram
    Baertram
    ✭✭✭✭
    About the gamepad keybinds all of sudden being a keyboard keybind: Someone explained me that if you e.g. pressed a keyboard key like ESC eben though you play by gamepad (gamead mode set to: ON in settings) the game will not think you want to use keyboard keybinds (as you pressed a keyboard key) and will disable gamepad keybinds.
    They will be disbaled until you press a gamepad key to activate it again and then the keybinds of the gamepad shoudl work again.

    Kind of confusing but also nice if you need to test something in gamepad mode without actually owning a gamepad :)
    But for you gamepad players it currently is weird I guess. I bet this ESC key will be excluded as it is a commonly used one.

    @ZOS_GinaBruno At best provide a setting to the users being able to disable this new features if they never ever want to use keyboard keybinds in gamepad mode. Alway nice to control this individually and you should really think about always adding a setting for such kind of changes (imho).
  • Genesiis
    Genesiis
    Soul Shriven
    Genesiis wrote: »
    Same problem here, the gamepad UI stays the same, but If I touch my keyboard it switches my skill bar from UP on Dpad, X, Y, B, LB, RB and LB+RB to Q, 1, 2, 3, 4, 5 and 6. The reverse happens when I touch my gamepad. I have no add-ons and my UI is set to default.

    This is how it is meant to be. However, the real issues here are, escape does not exit UI if in gamepad mode, and if Gamepad mode is set to ON, using a keyboard keybind to open a UI opens it with keyboard keybinds active, making an extra step to to actually do something in the UI.

    Example:
    Press [ I ] on keyboard to open inventory, press ( B ) does not exit, but changes to gamepad controls, then press ( B ) again will exit.

    This needs to be change to where if Gamepad mode is set to ON, then pressing any keyboard keybind that is set to open a gamepad UI needs to open with gamepad keybinds active by default.

    No, thats incorrect when Gamepad is set to ON it doesn't matter if you touch a keyboard or not you keep the same Gamepad UI. Furthermore if you use it as automatic and you touch the keyboard the UI will switch to the keyboard UI, but in my case the GamePad UI Remains the Same with my skill bar showing the input for keyboard.
    In The Beginning...
  • IsJustaGhost
    Genesiis wrote: »
    No, thats incorrect when Gamepad is set to ON it doesn't matter if you touch a keyboard or not you keep the same Gamepad UI. Furthermore if you use it as automatic and you touch the keyboard the UI will switch to the keyboard UI, but in my case the GamePad UI Remains the Same with my skill bar showing the input for keyboard.

    You misunderstand. It is not switching to keyboard UI. it switches to keyboard layout. As in the the keybind button group layout.
  • IsJustaGhost
    m9xo9usync72.png
  • Genesiis
    Genesiis
    Soul Shriven
    When I hit my space bar my UI does not change but my skill bar input switch to keyboard input with the same gamepad UI.
    In The Beginning...
  • IsJustaGhost
    That switch is intended. It's part of the added keyboard support "for" gamepad mode. Far example, the ability to switch gamepad UI tabs with keyboard keybinds such as inventory to craft bag.

    Now, personally I would say that if Gamepad mode is set to ON, not Auto, the binding should not switch while in the HUD, and gamepad controls should be default in any gamepad UI, even if you got there by pressing a button on the keyboard.
    Wile HUD is active, there has always been support for the keyboard while in gamepad mode. there is no need to switch.
    However, now it will change the icons for the skills. which does make sense. But, maybe this should only be done if Gamepad mode is set to Auto.
  • IsJustaGhost
    "ZOSDanBatson
    @ZOSDanBatson
    11:36
    So in regards to "On" vs "Auto", when the setting is Auto it should just switch between them like it used to. The thing that's new is that when the setting for gamepad UI is "On" it will show keybinds that reflect whatever the last input was. So if you are gamepad mode "On" but use a keyboard/mouse, you will see keyboard binds. THat's the feature, and that's working as designed."
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    "ZOSDanBatson
    @ZOSDanBatson
    11:36
    So in regards to "On" vs "Auto", when the setting is Auto it should just switch between them like it used to. The thing that's new is that when the setting for gamepad UI is "On" it will show keybinds that reflect whatever the last input was. So if you are gamepad mode "On" but use a keyboard/mouse, you will see keyboard binds. THat's the feature, and that's working as designed."

    Would have been nice if that comment was in THIS thread. BUT... it's also janky as h ell and not intuitive and makes you think everything is broken.

  • Genesiis
    Genesiis
    Soul Shriven
    If it ain't broke don't fix it!!!
    In The Beginning...
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    So you're telling me that, when playing on PC: if I have gampadui set to ON not auto... if I type in chat EVER... my keybinds in the ui will do this janky swap forever?

    Look, I don't have a degree in UI... but who thought that was a good idea? Does the UI team even use their own mess?

    And yes, I know people complained on PTS - where it took 5 threads to get a fix for the chat, at 3 weeks in. Ofc no one would listen to the people who have to use this UI all day, every day.
    Edited by CaffeinatedMayhem on November 1, 2021 11:21PM
  • Genesiis
    Genesiis
    Soul Shriven
    Genesiis wrote: »
    If it ain't broke don't fix it!!!

    I agree Gamepad set to "On" should revert back to the old system and Gamepad set to "Auto" can enjoy this lovely new system.
    In The Beginning...
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    You know what I was hoping for? Being able to reset dungeon level when I'm lead. Not having to switch to keyboard UI because crown (ME) can't switch levels to reset. Or maybe less lag so I don't get shamed for having to use a controller for acessibility in trials.

    Or maybe being able to use addons without generating LUA errors (I'm not expecting the UI replacement addons to work in gamepad, but at least be more tolerant of addons being ON in gamepad ui)

    Maybe even synergies and placement sensitive controls being more usable and not disappearing suddenly.
    Instead we get to fight against the entire UI swapping because I had to type in chat. Which, btw devs, is REALLY SUPER OFTEN ON PC.
    Edited by CaffeinatedMayhem on November 1, 2021 11:36PM
  • IsJustaGhost
    That's why I started making addons.
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    That's why I started making addons.

    Pretty sure you stil can't make AGS work in gamdpadui. Or make the gamdpad ui stop borking when it decides lead can't swap levels (it's not ever broken in keyboard, but you get 1 reset then you have to switch leads in gamepad)

    There are some things the UI team has to fix, because they don't allow addons to do as much in gamepad ui,
    Edited by CaffeinatedMayhem on November 1, 2021 11:46PM
  • IsJustaGhost
    Most addon devs just would not touch gamepad mode. It doesn't mean it's not possible. It would be up to the creators of AGS to make it work in gamepad mode.

    Just recently I've been helping make libFIlters3 gamepad mode compliant (not updated yet for live).
  • CaffeinatedMayhem
    CaffeinatedMayhem
    ✭✭✭✭✭
    ✭✭✭
    Most addon devs just would not touch gamepad mode. It doesn't mean it's not possible. It would be up to the creators of AGS to make it work in gamepad mode.

    Just recently I've been helping make libFIlters3 gamepad mode compliant (not updated yet for live).

    So, you do realize that none of the addons that do UI REPLACEMENT work in gamepad? it is literally not possible. There is no "compatibility" for overriding gamepad UI parts entirely. Substituting prices in inventory or putting timers on bars is about as far as it goes. Awesome Guild Store completely overrides the keyboard guild store UI. There is literally nothing in the API that allows the same functionality for gamepad. What I'm talking about isn't addon devs not wanting to do something, it's the ZOS API not allowing the same functionality for gamepad as it does for keyboard.

    I think you were intending to imply that "someone" should just write an addon to stop this ui thing. Except... ZOS DOES NOT ALLOW PLAYERS TO DO THAT. Not when talking about the overall gamepad ui interface.
    Edited by CaffeinatedMayhem on November 2, 2021 12:00AM
  • No_Lollygaggin
    I have an XBox Elite Series 2 in wireless use on PC and am having this bug on everything i touch. Game is honestly unplayable at the moment.
Sign In or Register to comment.