The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 6:
· [COMPLETE] EU megaservers for maintenance – February 7, 9:00 UTC (4:00AM EST) - 17:00 UTC (12:00PM EST)
· NA megaservers for patch maintenance – February 9, 4:00AM EST (9:00 UTC) - 10:00AM EST (15:00 UTC) https://forums.elderscrollsonline.com/en/discussion/627149/
· EU megaservers for patch maintenance – February 9, 9:00 UTC (4:00AM EST) - 15:00 UTC (10:00AM EST) https://forums.elderscrollsonline.com/en/discussion/627149/

ESO isn't using my mac's discrete graphics card?

Aetnaria
Aetnaria
Just recently I got clued in to the fact that ESO does not appear to use my discrete graphics card. Instead of using my AMD Radeon R9 M370X (2 GB), it only uses my integrated
Intel Iris Pro (1536 MB). I updated to Big Sur not too long ago, but would not be surprised if it has never used my discrete graphics card.

I changed my graphics settings to Highest in the game and relaunched it, but it still only taps the integrated chip.
Repairing the game did not change this.
In the UserSettings.txt file the only reference to graphics I could see was SET GraphicsDriver.7 "Vulkan"
According to https://www.amd.com/en/technologies/vulkan the AMD Radeon™ R9 Series is Vulkan-compatible (though they reference Windows and Linux OSes).

Is there some bworked setting somewhere I should toggle to fix this, or is this a known/widespread issue for macOS clients?
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    That setting you have refers to engine itself and not to hardware. You can check https://nathansnelgrove.com/how-to-force-your-macbook-pro-to-use-its-discrete-graphics-card-when-its-plugged-in/ and see if that helps. Which GPU to use is managed by system.
  • Aetnaria
    Aetnaria
    Yes, I can force the system to always use the discrete graphics card. System Preferences -> Battery -> Power Adapter -> uncheck Automatic graphics switching. Performance is definitely improved in ESO when I do this (though I still get the intermittent crash during dungeon boss fights, but that happened using the integrated graphics card too and started two ESO updates ago for everyone).

    But other games automatically switch to use my discrete graphics card when I launch them - like Minecraft and Terraria. Why doesn't ESO? Do I have an incorrect ESO setting, or is this just the state of ESO on mac?
  • Aetnaria
    Aetnaria
    Upon further play this weekend, by forcing the discrete graphics card to be running before I launch ESO I seem to be crashing half as often (once every other dungeon or so, sometimes less) instead of in every single dungeon (usually, but not always, at the boss fight) in addition to the noticeable performance improvement. So there is some impact there.

    I still do not know why ESO doesn't wave the flag to my OS to switch over to using the discrete graphics card the way the other games I try do though. I can only assume other mac players are unknowingly running into this as well?
    (You can see which graphics card is currently in use via Apple Menu - About This Mac - Graphics (it will list whichever is currently being used), or look for Activity Monitor - Energy - Graphics Card - Yes (No means they only use the integrated graphics card).)
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    It may be true. Nevertheless this is unlikely going to change soon so in the meantime you can check link I have provided as this theoretically should at least eliminate need to manually force discrete GPU use each time you start TESO. Unless ofc you also want to have this GPU to be disabled by default while charging your Mac.

    Also one more question: what is MULTI_GPU_CHECK value?
    Edited by alterfenixeb17_ESO on December 16, 2020 5:04PM
  • Aetnaria
    Aetnaria
    I did take a look at that link, thank you! However I do agree with the general principle of using the discrete graphics card only when a program demands it (when I'm gaming), and not simply whenever the laptop is plugged in (which is pretty much all the time). I don't need the extra juice to send an e-mail or look something up on the internet.

    To that end I installed the open source gfxCardStatus beta (see https://gfx.io ) which tells me which card is currently in use, and gives me a quick way to switch it.

    My computer is an edge case. I acknowledge this. Computers that do not have both an integrated and a discrete graphics card do not have this issue. Computers that have both but are also driving a second monitor at the time do not have this issue (the OS taps the discrete card automatically). My concern is that I am not the only person with this edge case that plays ESO.

    Apple has a lot of documentation that I do not comprehend at developer.apple.com, but it looks like Blender ran into the same issue (see https://developer.blender.org/T71342 ) and solved it by removing "<key>NSSupportsAutomaticGraphicsSwitching</key><true/>" from their Info.plist file and "attribs.push_back(NSOpenGLPFAAllowOfflineRenderers);" from elsewhere. Basically, they stopped telling the OS it was okay to switch to the integrated GPU for their stuff.

    Per https://forums.elderscrollsonline.com/en/discussion/comment/1427382
    SET MULTI_GPU_CHECK 0 or 1 // Pre-game check if using multiple graphics cards.
  • Aetnaria
    Aetnaria
    Sorry, if you were asking for the current value in my UserSettings.txt file, it is: SET MULTI_GPU_CHECK "1"
Sign In or Register to comment.