Update 40 featuring the Endless Archive is now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of October 2:
• [COMPLETE] ESO Store and Account System for maintenance – October 3, 9:00AM EDT (13:00 UTC) - 12:00PM EDT (16:00 UTC)
• Xbox: NA and EU megaservers for patch maintenance – October 4, 6:00AM EDT (10:00 UTC) - 12:00PM EDT (16:00 UTC)
• PlayStation®: NA and EU megaservers for patch maintenance – October 4, 6:00AM EDT (10:00 UTC) - 12:00PM EDT (16:00 UTC)

Light from the darkness quest

on the PTS and on the live server the quest is utterly bugged

interracting with the crystals are posible, how every they wont cath the light at all from the main becons at all, wich means you cannot progress trhoug the quest line at all.
This needs to be fixed or teh quest needs to be reworked completly. each time when a new pathc arrives, the main story line quests are getting bugged out utterly.
Another example in sancre tor when you face manymarco molag bals hand are not reaching out hes soul through the ancor and not pulling hes soul away from the ground.
the next one, is the Light from the darkness one as well. sience i cannot go through this quest i cannot give any bug reports, wich comes from the main storyline perspective.

please fix it ASAP.

PS: visual and art or model issue as well. the hip part of the empreror regalia is also got bugged both in PTS and both on live server.
the issue is teh same, hip parts are wants to falling apart from teh character models on each race and on each gender. (yes i tested all of them)
please fix those as well.
GM Of The Lusty Argonian ERP
GM Of THe Alessia Dynasty PVP Guild
GM Of The Guardians Of MiddleEarth
My Smiling Emperor Profile Picture: https://ibb.co/bsOM6n
  • Lannharr
    Same here! I'm stuck in the 'Light from Darkness' quest. The soul emitters' light ray won't turn on on both North and South pillars and now I'm stuck. I tried to exit the room and then in but nothing changed. It's weird because on my main character it worked flawlessly and I had completed the quest without issues.
Sign In or Register to comment.