Maintenance for the week of August 2:
• PC/Mac: No maintenance – August 2

So for some reason.....

chibear85
chibear85
✭✭✭
For some reason I can't use any add-on that has libstub as a library it causes all my locations on game map to be blank for example when I'm in cyrodiil if I hover over any location it gives no info not name of location not sieges number nothing any ideas? works fine when I turn off libstubbut then s'rendarr doesn't work combat metrics etc...
Edited by chibear85 on March 2, 2020 5:08AM
  • InaMoonlight
    InaMoonlight
    ✭✭✭✭✭
    Game just had a major overhaul you can expect about 1/5 of the addons not working, unless updated. :)

    Edit = Typos ... as usual. <;D
  • chibear85
    chibear85
    ✭✭✭
    All updated except libstub it doesn't update anymore and really isn't used by game anymore but some add-ons still use it in library and won't work without it funny thing is the add-ons work but it messes up game ui map
  • idk
    idk
    ✭✭✭✭✭
    ✭✭✭✭✭
    Libstub was updated 2/24/2020. Make sure yours is updated.
  • chibear85
    chibear85
    ✭✭✭
    I use minion so if it was updated it would of done it and on esoui website it says discontinued
  • chibear85
    chibear85
    ✭✭✭
    cf9xkc3taf0x.png
  • idk
    idk
    ✭✭✭✭✭
    ✭✭✭✭✭
    So it is not needed.

    Odd that it was updated a week ago and is not "out of date" in my game.

    Glad you solved your issue.
  • chibear85
    chibear85
    ✭✭✭
    Not solved not a Dev of any kind so have no idea how to fix or if there is a fix for it
  • Baertram
    Baertram
    ✭✭✭✭
    LibStub did not change in any way. All that was "updated" is the message inagme to see that it is obsolete now and you should context the authors to remove LibStub usage form their addons.

    LibStub was just telling the game to use the higehst version of a dependendy, which uses LibStub. Like LibAddonMenu-2.0 was there with several addons and some forgot to update the lib as they did include it in their addons.

    Addon1: LibAddonMenu-2.0 version r28
    Addon2: LibAddonMenu-2.0 version r20
    Addon3: LibAddonMenu-2.0 version r10

    So all LibStub did was to load all the versions and if any version was higher than the last loaded one it took this one as the "newest".

    But with Summerset there was introduced a better way to solve this:
    The txt files of thelibraris can tell they are libraries now and what version (## AddOnVersion: <unsigned integer>) now which will make the ingame vanilla UI addon manager load ONLY the highest version.
    LibStub is therefor not needed anymore and the libs need to strip it's usage + use their own txt files.
    -> The addon manager will only load the newest version properly if if finds a txt file with the libraries ## AddOnVersion: tag!
    The libraries need to provide a global variable so the adons can load the fucntionality with this instead of using LibStub now.
    like LibAddonMenu-2.0 introduced with version r28 the global variable "LibAddonMenu2".

    That's why addon devs need to remove LibStub calls like this:
    local LAM = LibStub("LibAddonMenu-2.0")
    to
    local LAM = LibAddonMenu2

    And in their addon#s txt file add LibAddonMenu-2.0 as dependency:

    ## OptionalDependsOn: LibAddonMenu-2.0>=28
    or
    ## DependsOn: LibAddonMenu-2.0>=28

    If you use ## OptionalDependsOn the addon will load if the library is missing.
    If you use ## DependsOn the addon will NOT load if the library is missing.
    If you add the >=number at the end the ingame vanilla UI addon manager will check if the dependency's version is higher or equal to the specified number.
    -> With LAM this is needed to assure that the gloabl variable LibAddonMenu2 is given!
    Or you need to build a hybrid way of loading the addon with an older LAM version and LibStub, or the global variable only:

    local LAM = LibAddonMenu2
    if not LAM and LibStub then LAM = LibStub("LibAddonMenu-2.0") end

    In the end this applies to ALL libraris, exsiting and new ones (new ones never use LibStub but only the global variable from the beginning then).
    So your addons need to make sure that the LibStub usage and calls in the addon code are changed to the global variables of the libraris.
    -> Each library got the global name of the variable you are able to use now in their description or changelog.

    Workaround for old libraries in outdated/discontinued addons:
    If your addons do not work properly anymore you should check the subfolders like "libs" in your addon folders and remove all the libs which are in there without their own txt file!
    In the txt files of these addons be sure to add the ## DependsOn: LibraryName tag for the libs you have removed.
    Make sure to download the newest version of each lib and install it into your live/AddOns folder directly (via Minion e.g.) so you got the newest version installed as "standalone library".
    This way, the changed txt files of the addons will assure, that the libs get loaded from the live/AddOns/LibraryName folder then e.g. (or any other addon providing the same library with the highest version number in a subfolder).

    Or read/ask the addon comments at www.esoui.com and check if there are unoffical patches or updates available.
Sign In or Register to comment.