Maintenance for the week of February 24:
• [IN PROGRESS] PC/Mac: NA and EU megaservers for patch maintenance – February 24, 2:00AM EST (7:00 UTC) - 12:00PM EST (17:00 UTC)

Connection timed out

Colinr1968
Colinr1968
Soul Shriven
I have reset my router deleted my saved data but still get connection timed out but all servers say all systems go but they can't be can they
  • Gilgameshi
    Gilgameshi
    Soul Shriven
    Same problem also. Reset router. Cleared everything. Restarted modem and called ISP to see if there was any blocks. Still can't connect. Even website home page doesn't load while on wifi. Loads on cell network. It's like my IP was blocked for no reason even though it's been working for a long time.
  • Daelinia
    Daelinia
    Soul Shriven
    I also can't login, for apparently no reason, my internet connection is fine I restarted my ps4 after restarting the app unsuccessfully and still no joy.
  • ZOS_BillE
    ZOS_BillE
    admin
    We are closing this thread since there are multiple threads open on this topic. Connections issues are currently being investigated on all megaservers. You can continue discussion in the thread below.

    pc na & other platforms crashed, launchers down, can't log in
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
This discussion has been closed.