Maintenance for the week of December 2:
• [COMPLETE] NA megaservers for maintenance – December 4,  4:00AM EST (09:00 UTC) - 7:00AM EST (12:00 UTC)
• [COMPLETE] EU megaservers for maintenance – December 4,  4:00AM EST (09:00 UTC) - 7:00AM EST (12:00 UTC)
• [COMPLETE] ESO Store and Account System for maintenance – December 4,  4:00AM EST (09:00 UTC) - 7:00AM EST (12:00 UTC)

"The Final Order" Quest Bugged, Cannot Progress

jmferris
jmferris
✭✭
In the quest "The Final Order", I am stuck on quest step "Find the Dragonguard Report". The quest marker is in the room in, but the report is not on the desk. However, if I look at my inventory, in my Quest Items, I do have the Dragonguard Report. So, it appears that while I do have the report, the quest step did not update, and I cannot progress any further.

It is for my character "Chaircat Meow Zedong". If it helps to troubleshoot for other people experiencing this, I was grouped with my wife, and she had picked it up off of the desk. It showed up in my inventory, disappeared from the desk, but my progression stopped completely.
  • mague
    mague
    ✭✭✭✭✭
    Sometimes it is required to open/use a quest item. Did you try to use the report in your inventory ?
    Edited by mague on June 13, 2019 5:45AM
  • jmferris
    jmferris
    ✭✭
    mague wrote: »
    Sometimes it is required to open/use a quest item. Did you try to use the report in your inventory ?

    I did, and it had no impact, I'm afraid. I also rezoned, ungrouped, rezoned again, and nothing changed with either the quest marker or the progression. :/

  • mague
    mague
    ✭✭✭✭✭
    jmferris wrote: »
    mague wrote: »
    Sometimes it is required to open/use a quest item. Did you try to use the report in your inventory ?

    I did, and it had no impact, I'm afraid. I also rezoned, ungrouped, rezoned again, and nothing changed with either the quest marker or the progression. :/

    Hmm.. support will probably tell you the same: Delete the quest, the quest item and try again. If it works do a ingame bug report that the quest is bugged when you do it as grouped couple.
  • jmferris
    jmferris
    ✭✭
    mague wrote: »
    Hmm.. support will probably tell you the same: Delete the quest, the quest item and try again. If it works do a ingame bug report that the quest is bugged when you do it as grouped couple.

    Good call. I went ahead and just did that and was able to push my way back through the quest without issue.

    Thank you!

Sign In or Register to comment.