The issues related to logging in to the North American megaservers have been resolved at this time. If you continue to experience difficulties at login, please restart your client. Thank you for your patience!

Laggy gameplay after Wrathstone

Blevil
Blevil
✭✭✭
I've read a couple of threads with people experiencing "micro freezes" though out certain regions but have noticed considerable lag even in areas where there are no players around. Also when porting to Ghratwood, players take a while to load even when I've been in the area for a while. They just appear as black silhouettes. The game just feels a bit laggyer than prior to update. This is more noticeable when spell weaving but not sure if it was intended.
|--| /-\ \/\/ /-\ | | `"*-.,
  • ZOS_BillE
    ZOS_BillE
    mod
    @Blevil

    Clearing your local save data as described below may help with the micro-freezes you're getting in different areas.
    1. From the PlayStation Dynamic Menu, navigate to Settings.
    2. Go to Application Saved Data.
    3. Click on Saved Data in System Storage
    4. Select "Delete"
    5. Select The Elder Scrolls Online.
    6. Place ticks next to ESO Save Data.
    7. Select [Delete] and then select [OK] to confirm your decision.

    Please let us know if this helps improve your performance or not.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • ValorieW
    ValorieW
    ✭✭✭
    I have the same issue, and I clear saved data religiously after every patch and it’s still a problem for me rn
  • ZOS_BillE
    ZOS_BillE
    mod
    @ValorieW

    If you're still getting lag after clearing your save data, you can open a ticket with customer support for further help.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
Sign In or Register to comment.