The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here:
Maintenance for the week of January 30:
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)
• [COMPLETE] PlayStation®: NA and EU megaservers for maintenance – February 1, 6:00AM EST (11:00 UTC) - 9:00AM EST (14:00 UTC)

Connection drops every 10-60 min

Soul Shriven

I play with my husband, we have two PC's Mac, both of them have MacOS and Windows 10 installed. I play under MacOS. The game was running smoothly until another patch about a month ago. After that, a problem occurred on both computers, accounts, game servers, both under MacOS and Windows 10: the game kicks us out in log-in menu every 10-60 min. Usually with no error message but sometimes it says, "An error has occurred. Please wait a few minutes".

We pinged ESO servers and it's fine 24/7, so to speak. Our internet connection is good enough, shows us it's 100MB. We tried to play with lowest graphics settings and we re-installed the game but nothing helped.

Then, we contacted the game support and sent 2 Report files: one under MacOS, the other one under Windows 10. We did what was recommended to us:

- repaired launcher and deleted all host.developer.(number).log files leaving only host.developer.log
- reset our machine's IP
- made sure ESO is added as an exception to our antivirus software
- reset the ProgramData folder
- made sure routers open all game outbound ports
- made sure the firmware of our router is up to date
- made sure modem/router is far from all electrical devices and does not coil up any excess signal or power cables

After that we had been told that the game doesn't support Bootcamp therefore the issue can't be solved. But I play under MacOS!

Can we get some help here? Because it seems like I was talking to bots all that time.
  • Nestor
    One thing to ask, do you play Wired or Wirelessly? Hint, Wired is better for gaming.

    When you opened the requisite ports, did you use Port Triggering or some other mechanism?

    Do you have any addons, if so, did you try without them?

    Have you tried a continuous ping to something like ping -t and let it run for about a 100 or so iterations, see if there are any drops
    Enjoy the game, life is what you really want to be worried about.

    PakKat "Everything was going well, until I died"
    Gary Gravestink "I am glad you died, I needed the help"

  • Tinumbra
    Soul Shriven
    Wired. Port mapping. No add-ons. No drops.
  • Tinumbra
    Soul Shriven
    Anyway, thank you for replying, Nestor. It's nice to know that at least one person cares.

    It was disappointing, not to say shocking, to realize there is no customer support here whatsoever. I really love the game but turns out it doesn't worth the money we payed for it. Due to the connectivity issues we can do neither group activities nor individual type of quests such as main quest.

    Although, for me, worse than that is the fact that technical support consists either of bots or people who don't actually read what their clients say and pretend doing their jobs by copy-pasting text.
    Edited by Tinumbra on March 26, 2018 6:32AM
  • alterfenixeb17_ESO
    Tbh I have also noticed that connection issues at least to EU servers recently became more popular (freeze game and then disconnect after a minute or so). Network connection works great, pings are normal when testing it (using speedtest). It's only about connecting to game servers.
  • phobi
    Since the last patch I cant even play for 2 minutes, disconnects all the time...
  • Tinumbra
    Soul Shriven
    Thank you, everyone. I found a solution for my problem: Free OpenVPN.
Sign In or Register to comment.