Curiously low performance on multi-core xeon

Jasiek95
Jasiek95
Soul Shriven
Hello everyone, not many people running my setup so I thought I'd inquire about it here in the forum.

I've been playing the game for about 2 months now and really enjoying it. But, I'm getting really frustrated at how poorly my PC is performing, especially in crowded zones with multiple players. Usually on Ultra I net around 40-50 FPS and sometimes 60 with little activity around me, but as soon as I enter, say, Mournhold or Rawl'kha, it drops down to 20-30. My CPU during this time sticks around 10-15%, even during large fights or crowded zones the usage doesn't increase to accommodate demand. My GPU meanwhile sits around 40% on ultra and low (regardless of what settings I tinker with) and I'm yet to see it shoot past the 60% mark.

The client seems to prefer one thread, which usually hovers around 90% on Ultra-High and remains the same even when I choose the lowest possible settings (640x480) with no increase in FPS. All the other threads meanwhile are seldom used or around 5-10% (only time CPU usage increases is when I change graphical settings, it then shoots up to 100% on all threads).

What surprised me was when my sister, with a xeon x5450 from 2006, a GTX 960 2GB and 6GB RAM was getting 60FPS stable at 1680x1050 on ultra in the same zones as me while I was running Low with 1366x768 and barely getting 40FPS with my superior specs. In other CPU intensive games like Battlefield 1, Planetside 2 and Ashes of the Singularity I generally get a stable 60FPS on Ultra, High and Medium respectively.

At this stage I've tried numerous proposed panaceas yet to no avail. This includes: Disabling all my Add-ons, OCing my GPU by 15%, OCing my CPU by 10%, toggling shader-cache in Nvidia control panel, trying all DSR options, all power options, maximum pre-rendered frames, toggling V-Sync and Triple buffering, disabling high resolution shadows in UserSettings.ini as well as all the tweaks mentioned here:. Heck, I even un-parked my cores!

When I was sat, scratching my head and wondering why my sister's rig was performing better I realised the main difference between our rigs -- aside from the older architecture and lack of hyper-threading -- her 4-cores were obviously doing better than my 6, so i deactived two of them and turned off hyper-threading. Voila, 20FPS increase instantly. Now with 4-cores, each core-usage was around 70-80%, sometimes 90-95% in intense fights or crowded zones and my GPU usage also shot up to around 60% (but didn't increase any higher than when I had 6 cores and hyperthreading enabled).

Obviously 4 cores and no HT on a CPU capable of more is not sustainable, and I had to re-enable them to play other, more-demanding titles. Has anyone had any luck under similar circumstances? Not many people -- better yet, anyone! -- seem to be having problems with their xeon CPUs so i'm not sure if it's just my particular CPU, or if this is more common among processors with similar core/thread counts.

TL;DR:

Hex-core Xeon only using 1 core out of 6 regardless of graphical settings and with all addons disabled. Have tried countless performance tricks with no success until I disabled HT and 2 cores. Usage shot up to 70-80% per core and 20FPS increase noticed instantly but still underperforming as I'd like all 6 cores and threads working.

Specs:
OS: Windows 10 Professional 64-Bit
Motherboard: ASUS P6T-Deluxe V2
CPU: Intel Xeon x5650 ~4.4GHZ
GPU: ASUS GTX 1060 Turbo 6GB
RAM: 18GB DDR3 ~1600MHz (OC from 1333 MHz)
SSD: Crucial MX300 525GB SATAIII SSD

Thanks guys!
  • Idinuse
    Idinuse
    ✭✭✭✭✭
    Just a thought, but wouldn't using these settings in the UserSettings.txt do pretty much the same as disabling 2 cores and HT in Bios?
    SET MaxCoresToUse "4"
    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"
    

    So that you don't have to change it on Bios and other games can use all 6 cores and HT?

    Also, check on your nVidia panel to make sure PhysX is using your GPU and not set to CPU or a MB GPU unit.
    Edited by Idinuse on December 21, 2017 3:10AM
    Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium dolorem que laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos qui ratione voluptatem sequi nesciunt. Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. Ut enim ad minima veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur? Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem eum fugiat quo voluptas nulla pariatur?
  • Jasiek95
    Jasiek95
    Soul Shriven
    Idinuse wrote: »
    Just a thought, but wouldn't using these settings in the UserSettings.txt do pretty much the same as disabling 2 cores and HT in Bios?
    SET MaxCoresToUse "4"
    SET RequestedNumJobThreads "0"
    SET RequestedNumWorkerThreads "0"
    

    So that you don't have to change it on Bios and other games can use all 6 cores and HT?

    Also, check on your nVidia panel to make sure PhysX is using your GPU and not set to CPU or a MB GPU unit.

    Hey! Thx for replying to my thread!

    I've tried both options that you suggested and my results are the same. In regards to the "SET MaxCoresToUse" command line, it's not as effective as disabling two cores in BIOS unfortunately.
Sign In or Register to comment.