Can't place sittable chairs in Earthtear Cavern

bellatrixed
bellatrixed
✭✭✭✭✭
This is an issue which I only noticed today when I tried to add one of the Daedric Thrones... no matter where I tried to place the throne, I never could get it to be green/sittable--just yellow. I thought maybe it was just the Daedric Throne that was bugged, but when I tried to place other chairs (which used to work in the Earthtear Cavern) they were also yellow, even on perfectly flat surfaces.

I am only having this problem in Earthtear Cavern--my other houses can have chairs (including the Daedric Throne) placed normally.

Anyone else having this issue?
Crescent Pact | NA/PC Roleplay; Knights, Supernaturals, and Scholars
ESO Roleplay | RP community for all factions/servers/platforms
  • ixie
    ixie
    ✭✭✭✭
    I don't own earthtear cavern, however I have noticed when trying to place a chair on an uneven surface don't use the right click, maybe this will help
    PC EU

    Xelwen - Bosmer Warden
    Ixie - Breton Nightblade
    Paints-With-Frogs - Argonian Nightblade
    Swee Troll - Crafter Dragonknight
Sign In or Register to comment.