Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
From the API patch notes highlights post:Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
CodeInject wrote: »From the API patch notes highlights post:Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
Thank you very much, didn't find that on google.
GetBagUseableSize(BAG_BANK) + GetBagUseableSize(BAG_SUBSCRIBER_BANK)
That should be the correct usage, right?
CodeInject wrote: »From the API patch notes highlights post:Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
Thank you very much, didn't find that on google.
GetBagUseableSize(BAG_BANK) + GetBagUseableSize(BAG_SUBSCRIBER_BANK)
That should be the correct usage, right?
Afaik the BAG_SUBSCRIBER_BANK constant gives you the additional size, not the whole size of your bag, that's the reason for the +BAG_BANK.Kaymorolis wrote: »CodeInject wrote: »From the API patch notes highlights post:Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
Thank you very much, didn't find that on google.
GetBagUseableSize(BAG_BANK) + GetBagUseableSize(BAG_SUBSCRIBER_BANK)
That should be the correct usage, right?
Wouldn't GetBagUseableSize(BAG_SUBSCRIBER_BANK) give you the total number available in a subscribers bank? If that returned 0 (ie not an ESO plus member) then you should try GetBagUseableSize(BAG_BANK).
You probably don't want to add them together because the result could be more than is actually available.
CodeInject wrote: »Afaik the BAG_SUBSCRIBER_BANK constant gives you the additional size, not the whole size of your bag, that's the reason for the +BAG_BANK.Kaymorolis wrote: »CodeInject wrote: »From the API patch notes highlights post:Subscriber Bank
A new bank bag has been added to the game for ESO Plus subscribers and is named BAG_SUBSCRIBER_BANK. The size of the bag is the same as BAG_BACKPACK. We have also added a new bag function, GetBagUseableSize(bagId), to return how many usable slots a bag has. This will return 0 for the subscriber bank if the player does not have ESO Plus. This new bag also necessitated some changes in the lua inventory objects to support multiple bags appearing in a single inventory view. Look out for functions that once took inventoryType now taking bagId as an additional parameter.
Thank you very much, didn't find that on google.
GetBagUseableSize(BAG_BANK) + GetBagUseableSize(BAG_SUBSCRIBER_BANK)
That should be the correct usage, right?
Wouldn't GetBagUseableSize(BAG_SUBSCRIBER_BANK) give you the total number available in a subscribers bank? If that returned 0 (ie not an ESO plus member) then you should try GetBagUseableSize(BAG_BANK).
You probably don't want to add them together because the result could be more than is actually available.