Maintenance for the week of January 27:
• PC/Mac: NA and EU megaservers for patch maintenance – January 27, 4:00AM EST (9:00 UTC) - 8:00AM EST (13:00 UTC)
• ESO Website for maintenance – January 27, 1:00PM EST (18:00 UTC) - 4:00PM EST (21:00 UTC)

Mouse sensitivity going nuts.

ofenergy
ofenergy
Soul Shriven
I'm a new ESO player, and I'm loving the game so far, only a few hours in. The only thing that's holding me from playing this game more is the mouse sensitivity wackiness.
Every 10 seconds or so my mouse sensitivity will spike for a second or two, making me lose control of everything. I've read things on the internet of disabling display scaling on high DPI settings, but that didn't do anything.

I have a Razer Naga Chroma, and I'm on the latest drivers.

This is kind of a game breaker for me. Any help would be appreciated.
  • Fyaal
    Fyaal
    ✭✭✭
    Same issue. It goes in and out though. Never seen it happen every 10 seconds.
    Fyaal - EP Stam DK Grand Overlord
    Invictus
    Nexus Haxus
    Hijinx
    IR
  • FleetwoodSmack
    FleetwoodSmack
    ✭✭✭✭✭
    Are you guys running Steam? If so, open your Task Manager and end the RazerInGame(I forget the rest of the string).exe task and swap back to the game and it should return to normal. It has a conflict with the Steam Overlay. Now if you're not running Steam, it could also conflict with other things that overlay in the game, buuuuuut it's hard to say. Worth a shot though!
    Tell me lies, tell me sweet little lies!
  • Turdferguson2
    Turdferguson2
    Soul Shriven
    Hmm I wonder if this is my issue as well. I also use a Razer Naga Chroma but whats weird is I never had this problem before up until this latest patch. Now my cursor continues to move after I looked in a certain direction. I'll have to try this though.
  • Mark3DMan
    Mark3DMan
    Soul Shriven
    I know this is an old post but I bumped up to this and found a solution on my system. Problem for me was too high polling rate on my mouse. I use SteelSeries Rival 310 and default polling rate is 1000. I made a profile for ESO that has the polling rate set to 250. No more camera clipping for me.

    Others have found solutions by switching between fullscreen and windowed fullscreen. Adaptive sync/vsync has also been a problem for some. Hope some of these tips helps someone. I have had this polling rate problem in other games aswell like Divinity Original Sin 2.
Sign In or Register to comment.