Pretty slow

MrChompy
MrChompy
Hello guys,

Im playing eso on my Imac 3,2 GHz Intel Core i5, AMD Radeon R9 M390 2048 MB, (Retina 5K, 27-inch, Late 2015)
But lately im having a bit trouble with loading content in the area, especially when i walk further, blurry buildings and people are fully black (hey, no racism here)
Does anyone know how this is possible, because i think my mac is pretty fast and its new too. it takes just pretty long to load content etc.

If someone has any tips and tricks, please let me now :)

Thanks!
Chompy
  • MrChompy
    MrChompy
    know* ;D
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    Long content loading may point towards networking issues (such as big latency). If standard procedure does not resolve this issue (close gam,e close launcher, restart router/modem) then this is probably something server related or bug in client.

    By any chance did it start with recent patch?
  • MrChompy
    MrChompy
    i really dont know, i dont think its my internet. i never really have a disconnections. but i dont play this game for a long time to prolly 1,5 month only. but yes when i started playing i didnt really have this issue
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    What resolution and what settings are you using? Is the problem new or since One Tamriel launched? You might try reducing draw distance. What specific CPU do you have. The things you describe sound like the CPU is being taxed.
  • MrChompy
    MrChompy
    resolution: 2560x1440

    Atm im trying to play on this:

    graphics quality: custom
    Texture quality: medium
    SubSampling quality: High
    Shadow + water: Low

    Max. particle systems: 1000
    Particle suppression distance: 60
    view distance: 60

    The rest of the options from Ambient till Sunlight is OFF except Grass is ON. i do think it has to do with my CPU cuz i see it pop up to over 100% sometimes if i check my activity monitor, its mostly around 40-70
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    I just realized you are on Mac. I found your post via Recent option. My bad. I don't know if it differs on Mac but on PC this game in crowded areas will be limited by CPU. I often will have my GPU downclock while fps is under 60. Elden Root and Rawl'Kha are good examples.
    Edited by JasonSilverSpring on November 24, 2016 9:41PM
  • alterfenixeb17_ESO
    alterfenixeb17_ESO
    ✭✭✭
    I just realized you are on Mac. I found your post via Recent option. My bad. I don't know if it differs on Mac but on PC this game in crowded areas will be limited by CPU. I often will have my GPU downclock while fps is under 60. Elden Root and Rawl'Kha are good examples.
    Actually the issue may not be related to that. I for instance since recent patch find that I can get those issues mostly in Cyrodiil when trying to sprint on my mount while such Mournhold works as expected.

    Granted that this is unlikely client's issue and possibly something network related rather.


    @MrChompy, you may want to try and reduce further those settings. Also how much RAM does your Mac have? I for one have 24 GB but at the time when I had just standard 8 GB I had such issues in every place (not just Cyrodiil) - TESO process can easily take 5-6 GB (+ you need memory for system and so on). Your settings seem to be same as mine while I have GeForce GTX 775M instead
Sign In or Register to comment.