The PlayStation® Network service interruption has been resolved. Thank you for your patience!
Maintenance for the week of February 25:
• PC/Mac: NA and EU megaservers for patch maintenance – February 25, 3:00AM EST (08:00 UTC) - 10:00AM EST (15:00 UTC)
• Xbox One: NA megaserver for maintenance– February 27, 4:00AM EST (09:00 UTC) - 12:00PM EST (17:00 UTC)
• Xbox One: EU megaserver for maintenance – February 27, 4:00AM EST (09:00 UTC) - 7:00AM EST (12:00 UTC)
• PlayStation®4: NA and EU megaservers for maintenance– February 27, 4:00AM EST (9:00 UTC) - 7:00AM EST (12:00 UTC)
The Wrathstone DLC Game Pack and Update 21 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/discussion/454456/

CAN NOT LOAD CHARACTER

XoXJulietteXoX
XoXJulietteXoX
✭✭✭
Can not load character. My last log in is Coldharbour. Wont load in after update. ESO y yu do dis to meee!? Come on. I've closed the app, turned off my ps4, ran a speed test (154mbps btw), reset my router/modem, and then turned my ps4 back on, still doesn't work. ESO, please help.
  • katestone
    katestone
    Soul Shriven
    I haven't been able to load any of my characters since one tamriel dropped either! Ppl have been saying its because of the area i logged off in and that there is a high volume of players there. yes all of my toons are in popular places, but i have tried logging in through out the day and nothing. Also tried late at night and early this morning.. takes me straight back to start screen.
  • Synuia
    Synuia
    Soul Shriven
    Im unable tologgin in either since the new undate. My character in out in the desert of sential by the outlaws door. Not a populated area at all.
  • Ww91jBGaHwa7
    Ww91jBGaHwa7
    Soul Shriven
    I'm in the same boat.

    Can't even load my character. It doesn't seem to be my internet (as I can play other multiplayer games), I've also tried deleting my save file. Nada, still can't load my character.

    I'm seriously regretting my purchase.
Sign In or Register to comment.