Maintenance for the week of June 17:
• PC/Mac: NA and EU megaservers for patch maintenance – June 17, 4:00AM EDT (8:00 UTC) – 8:00AM EDT (12:00 UTC)
• ESO Store and Account System for maintenance – June 17, 10:00AM EDT (14:00 UTC) – 12:00PM EDT (16:00 UTC)
• Xbox One: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 10:00AM EDT (14:00 UTC)
• PlayStation®4: NA and EU megaservers for patch maintenance – June 19, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Disconnecting regularly when loading new areas or trying to join PvP

TheMunz
TheMunz
Soul Shriven
I just got this game about a week ago, and I've been having some major issues when trying to enter certain things. There have been a number of dungeons I've tried to enter where on the loading screen it says "This may be an unusually long load time" and then disconnects, most of them eventually work after several tries but some (most recently Ondil in Auridon) don't let me in at all.

I've also tried joining PvP, but when I try entering Cyrodiil from the Campaigns menu it goes to a black screen and then I get disconnected.

I've never gotten any random disconnects since I started playing, the only times I've gotten disconnected were when I was on some sort of loading screen. I've googled this issue a bunch, haven't found any substantial solutions from forum posts, and the general advice in the Knowledge base for handling disconnects (changing my DNS) hasn't fixed the problem.
Sign In or Register to comment.