Update 43 is now available for testing on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of July 22:
• [COMPLETE] Xbox: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) - 12:00PM EDT (16:00 UTC)
• [COMPLETE] PlayStation®: NA and EU megaservers for patch maintenance – July 24, 6:00AM EDT (10:00 UTC) – 12:00PM EDT (16:00 UTC)

Launcher Crashing and now in-game crashing

Lord_Xp
Lord_Xp
I have been submitting crash reports out the wazoo for a while now. I have submitted tickets and replied with that repair text file and still no word on any of my problems I'm currently having.

First Problem
When I press "Play" on the Launcher it would launch the game and there was no screens, but I could hear the game just fine. That doesn't happen anymore. Now it's opposite. The game screens are there and no sounds are being played. I have to repair the game to fix this. But it eventually comes back

Second problem
Instead of using the Launcher, I just go through my files to the ESO Application. This has been working for a while where I run into no problems. But the past few days, I'll launch the game through this method but will eventually crash while in mid game.

What I've tried so far
  1. I have repaired the game so many times, I've lost count
  2. I have uninstalled and then reinstalled the game
  3. I have looked through technical problems and tried their various methods to fixing anything
  4. I have submitted tickets to the above problems and responded back with the Repair Text file it requests I reply with which I haven't heard anything since. Thats been over a week now for the first problem I wrote above

I am really running out of patience for this game and it's crashing. I really like the game and don't want to cancel my subscription but I'm losing my mind over it.
[PC][NA][EP]

A head on a pike no longer conspires
Sign In or Register to comment.