The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts

Can't log in on Xbox

MadSpoon
MadSpoon
Soul Shriven
Main issue: I can't get past the "PRESS A TO START" screen.

Starting from a powered off xbox.
Select eso.
Watch Bethesda and zenimax logos.
Get to "PRESS A TO START" screen.
Press A.

That is as far as I can get. The game is not frozen as I listen to the background music and watch the smoke float around.

Things I have tried:

Waiting a long time. After 15 or so min the controller will time out, so I have tried keeping it active for an hour. This did not help.
Press the home button and force quit eso and reload again. Same issue.
Completely turn off the xbox and turn it back on again. Same issue.
Reset modem, router, and xbox. Same issue.
Wait a day and try all of the above again. Same issue.

Internet connection is good, as I can watch Netflix and Hulu on the xbox. I can also play Destiny and other games.

This issue has been persistent for about a week.
  • MadSpoon
    MadSpoon
    Soul Shriven
    I have been making a daily attempt and today it let me log in.
Sign In or Register to comment.