Xbox Live™ is currently experiencing a service interruption. Please check here for status updates:

ESO.exe closes just seconds after it is started.

This is a new problem that has started in the last week. No new software has been installed. I have tried uninstalling, disabling all firewalls/antivirus programs. Here is a video that shows exactly what it is doing.

  • JTorus
    Start -> run -> type in eventvwr -> OK

    Find the Application log and open it up. Find the time where you last tried to run eso.exe (just try to run it again so it'll be recent).

    Show us what the error says in there, if it logs something (it should)

    You may have a corrupted addon or problematic settings.
    Navigate to %userprofile%\Documents\Elder Scrolls Online\ (copy paste that in your run window)
    Rename your live folder to something like livebackup

    If the game successfully launches then you know where your problem lies.

  • Dizzmalb14_ESO
    It turned out to be caused by a windows update. Haven't had the same problem since I stopped it from updating.
Sign In or Register to comment.