Maintenance for the week of June 24:
• PC/Mac: No maintenance – June 24
• ESO Store and Account System for maintenance – June 26, 4:00AM EDT (08:00 UTC) – 12:00PM EDT (16:00 UTC)

Improved DSR Quality - Smoothness Bug with native Full HD displays @ DSR Factor 4.00x (UHD)

Elderpatriot
Elderpatriot
✭✭
Hi,

just in case any other Nvidia user encountered the same problem as myself i am posting this thread to help out. Its about DSR (Dynamic Super Resolution) not applying the Smoothness factor at 4.00X DSR. Instead of prefering 0% for best picturequality it always blures the picture with default value of 33%. I postet a simelar thread at the Nvidia Forums, may be it is a problem related to the graphics driver. Continue to read for a solution. If you do not have this problem at all i would like to get your respond aswell.




********** original post *************

Hello everybody,


Why do i post this ?

I noticed strange behaviour of the Nvidia DSR Feature in Elder Scrolls Online. Elder Scrolls Online looks great in ultra settings - still it lacks an effective Antialiasing. The available FXAA still produces very noticeable flickering at edges during movement @ 1080P. In 2160p DSR (Dynamic Super Resolution) there is a huge benfit in picturequality. But the default 33% DSR Smoothness filter can not be changed and applies to much blur - no matter what value i pick in the Nvidia Control Panel, it has not effect ingame.

Then i noticed something else: The resolution @ desktop has a profound impact on the DSR Quality - although the game itself is rendered in fullscreen (not windowed fullscreen).


The Bug

DSR Smoothness is fixed to default value (33%), when i am playing fullscreen with 2160p Dynamic Super Resoltion and my desktop is setted @ native 1080p. Changed values have no visuell influence ingame.



My specs


native 60Hz Full HD display
Windows 8.1 64-Bit
MSI GTX 970 4GB gaming 4g
Intel Xeon E3 1231V3
8GB RAM
Nvidia Driver 352.86


My observations and workaround


1. UHD DSR (2160p) is working, but ignores completly the DSR-Smoothing. TESO always seems to pick the default value of 33% smoothness, which results in a slightly blurry image. Changing to extrem values such as 100% or 0% and restarting does not have any effect. The Icons of the minimap have still the same size as they apear in 1080p.

2. If i select 2160p DSR @ desktop, the DSR-Smoothin ingame will still not apply.

3. If i switch now ingame fullscreen -> windowed -> windowed fullscreen and then back to fullscreen, DSR-Smoothing will finaly adapt to the setted values. 0% is very sharp and clear, 100% is very blurry. The minimapicons are now much smaller. (as they should be, because DSR is known to cause this effect).

4. If i pick now again a different desktopresolution besides native 1080p or 2160p, the ingame UHD-DSR looses a lot of quality, getting grainy und edges more aliased - although it is still fullscreen UHD-DSR 2160P.

5. If i switch now back to 1080p ingame (still 2160p DSR @ desktop) the picture is more blured than usual @ 1080p.




That influence of the used desktopresolution is strange and it should not happen in fullscreen at all. My driver is updated and i just want to post this bug - maybe it can be fixed somehow. Just tested in StarCraft 2 - there the DSR and its DSR-smoothness adapts perfectly no matter what resolution my desktop is currently using. Every Resolution behaves as expected. So this problem seems to be related to TESO.

So if u want DSR-Quality AND best sharpness (0% Smoothness) in TESO @ 3840 x 2160 DSR:


1. Enable DSR in Nvidia Control Panel (Factor 4.00x for Full HD monitors)
1.Set DSR-Smoothness to 0% and apply settings
2.Set Desktop to 3840 x 2160
3.go ingame and pick 3840 x 2160
4.switch to Windowed, Window Fullscreen and then back to Fullscreen.
5. Enjoy the now working DSR and sharpness.


How this behaviour affects other displays than Full HD is unknown, because i do not own a monitor with higher resolution.
  • blackpearl80
    blackpearl80
    Soul Shriven
    Hi, some questions since I don't understand if my DSR is working or not:

    1) Is normal that under DSR fullscreen TESTU the steam overlay doesnt get resized, like I don't know, games like bioshock infinite, Skyrim and Dishonored?

    2) It's normal that under fullscreen, making a screenshot, either with the steam screenshot button, or using external program for videorecording (ie. Dxtory or perhaps frap?) the screenshots coming out @1080p?

    3) It's normal also to have to force set desktop resolution to 1440p for play TESTU while in Fullscreen (with desktop at 1080p)?

    I have play few games now with DSR, the 3 above are working plus Far Cry2. All this games get Steam Overlay resized.
    Thank you.
  • Elderpatriot
    Elderpatriot
    ✭✭
    I do not use STEAM - so i can not tell you anything about that.


    What i noticed:


    *****Ingame DSR 4.00 (3840 x 2160) + Desktop native 1920 x 1080*****

    Screenshots and Videos will be safed at 1080p (if setted to full screen/ingame recording). The Ingame UI does NOT get resized. The Ingame Quality is clearly betterr than native 1080p - still the DSR Smoothfilter is NOT applied.



    *****Ingame _DSR 4.00 (3840 x 2160 )+ Dekstop DSR 4.00 aswell (3840 x 2160)*****

    Pick Windowed mode ingame and then go back to full screen. Now the Minimap Icons are resized to smaller versions - rest of the UI stays same. The DSR-Smoothing is now applied as well, as it should. Change it to any value in Nvidia control panel as you prefer.

    If you take now Screenshots or Video recordings (caputere size @ ingame resolution), Videos and Pics will be safed as 3840 x 2160 files.





  • blackpearl80
    blackpearl80
    Soul Shriven
    Mmh weird but suppose no other choice but to set desktop to DSR. Thank you.
  • Elderpatriot
    Elderpatriot
    ✭✭
    Now they have changed it: The interface is completly scaled down, when picking the same desktop resolution for borderless windowed Fullscreen DSR. Its unplayable now in 4K, texts are so tiny youre going to get a headache. Only choice: Play in native Fullscreen for readable interface, pick prefered DSR and ignore the missing DSR-Smoothing, which i really miss and is a quality feature of DSR.
    Edited by Elderpatriot on July 29, 2015 1:30PM
Sign In or Register to comment.