Can't enter group dungeons due to bug.

So I am playing my newly created alt, currently level 19. I find people to do the low level dungeons with, but one problem... Everyone in our group is getting "Your attempted jump failed because your veteran rank is not high enough". Why is this? No one is above level 19, and there is not even an option to set a dungeon to veteran mode if you are below veteran rank 1. We have tried reforming group, re-logging, breaking group and entering individually. Every time, each of us get the same message.
  • Ourorboros
    I ran into the same issue. Read on a post here that if you group with a vet, vet is grp leader. and vet changes dungeon level to normal dungeon it will fix the issue. I can't verify this.
    Breton Sorcerer Maester.White - BB meets GoT >Master Crafter< { 9 Traits completed 4/23/15 }
    TANSTAAFL--->There ain't no such thing as a free lunch.....Robert Heinlein
    Women and cats will do as they please, and men and dogs should relax and get used to the idea....Heinlein
    All those moments will be lost in time, like Time to die. "Blade Runner"
    ESO: the game you hate to love and love to hate....( >_<) May RNG be with you (*,_,*)
  • SeattleSiren
    A group of us tried as well; we tried to get into BC..tried logging, changing leader around, even had a Veteran join us..and they luck. It just kept saying we weren't higher enough Vet Rank... yet when I recalled to area it put me inside the dungeon. This needs to be looked into..We can't finish up this map until we can do this dungeon.
  • ZOS_The_Adoring_Fan
    Make sure that your Dungeon Mode is set to Normal instead of Veteran. You can find this under the Group menu (P) in the top middle of the pane.
    Dungeon Team Content Designer - The Elder Scrolls Online
    Staff Post
Sign In or Register to comment.