The Scribes of Fate DLC and Update 37 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of February 6:
· [IN PROGRESS] NA megaservers for patch maintenance – February 9, 4:00AM EST (9:00 UTC) - 10:00AM EST (15:00 UTC)
· [IN PROGRESS] EU megaservers for patch maintenance – February 9, 9:00 UTC (4:00AM EST) - 15:00 UTC (10:00AM EST)

No longer possible to interrupt/bash with mouse buttons (default keybindings)

spesimen
spesimen
I recently reactivated and I have noticed some newly introduced bugs with mouse keys/bidnings.

Holding block using right mouse button then pressing the left mouse button should interrupt/bash but instead light or heavy attack is triggered. The only way I can interrupt or bash now is using regular/secondary key binding mapped to the keyboard.

If I release block then press both at the same time I can sometimes trigger the interrupt animation but very rarely. Most of the time i just starts an attack.

Additionally some mouse buttons are no longer recognized by the game and unable to be mapped. I can currently only map left/right and mouse wheel but no other keys (this used to work as well). I managed to work around this manually remapping the mouse keys using logitech software. Could these two things/bugs be related perhaps?
  • Moonraker
    Moonraker
    ✭✭✭✭
    The key mapping was noted in another thread and a fix should be in soon I believe.

    I have no issue with blocking as you describe so not sure what is causing that.
  • tttopperub17_ESO
    spesimen wrote: »
    I recently reactivated and I have noticed some newly introduced bugs with mouse keys/bidnings.

    Holding block using right mouse button then pressing the left mouse button should interrupt/bash but instead light or heavy attack is triggered. The only way I can interrupt or bash now is using regular/secondary key binding mapped to the keyboard.

    If I release block then press both at the same time I can sometimes trigger the interrupt animation but very rarely. Most of the time i just starts an attack.

    Additionally some mouse buttons are no longer recognized by the game and unable to be mapped. I can currently only map left/right and mouse wheel but no other keys (this used to work as well). I managed to work around this manually remapping the mouse keys using logitech software. Could these two things/bugs be related perhaps?

    I noticed this in game when the interrupt/bash keybind to the Command was patched. Sometimes I can get the interrupt with the mouse keys, most times I cannot. I just attributed it to game lag and command stacking and tried to retrain my brain to use the Command key. (aside: just putting the open apple key in for old times sake, I was sad when it changed to ⌘ )
  • Moonraker
    Moonraker
    ✭✭✭✭
    spesimen wrote: »
    I recently reactivated and I have noticed some newly introduced bugs with mouse keys/bidnings.

    Holding block using right mouse button then pressing the left mouse button should interrupt/bash but instead light or heavy attack is triggered. The only way I can interrupt or bash now is using regular/secondary key binding mapped to the keyboard.

    If I release block then press both at the same time I can sometimes trigger the interrupt animation but very rarely. Most of the time i just starts an attack.

    Additionally some mouse buttons are no longer recognized by the game and unable to be mapped. I can currently only map left/right and mouse wheel but no other keys (this used to work as well). I managed to work around this manually remapping the mouse keys using logitech software. Could these two things/bugs be related perhaps?

    I noticed this in game when the interrupt/bash keybind to the Command was patched. Sometimes I can get the interrupt with the mouse keys, most times I cannot. I just attributed it to game lag and command stacking and tried to retrain my brain to use the Command key. (aside: just putting the open apple key in for old times sake, I was sad when it changed to ⌘ )
    The issue when it showed the Command key when updated in Controls > Keybindings was fixed a while ago. It was just required to set it to how it is now. Not sure why it would change the actual actions.

    Just to be clear on this;

    Block = Right Mouse Button click
    Interrupt = Left & Right Mouse Button click
    source

    I find that trying to press simultaneously often just causes the Right Mouse Button Click Attack and maybe an Interrupt also. To ensure it actually Interrupts, I press the Right Mouse key first and then the Left Mouse key just after will give 100% Interrupt animation. I'm guessing that latency and lag can cause it not to work correctly when they are press at the same time.
    Edited by Moonraker on July 7, 2014 1:18PM
  • spesimen
    spesimen
    Moonraker wrote: »

    Just to be clear on this;

    Block = Right Mouse Button click
    Interrupt = Left & Right Mouse Button click
    source


    This is how I always did it before and is trying to do it now.

    What happens now is I hold block using right mouse button, then press left mouse button to interrupt. This triggers a light attack. Attempting this a couple of times causes me to stop blocking even though I am still pressing down the right mouse button. I have to release it then re-press it to start blocking again. Interrupting with a key bind (currently mapped to V) while blocking works as intended and does not "break" block.
    Edited by spesimen on July 7, 2014 4:51PM
  • Moonraker
    Moonraker
    ✭✭✭✭
    spesimen wrote: »
    Moonraker wrote: »

    Just to be clear on this;

    Block = Right Mouse Button click
    Interrupt = Left & Right Mouse Button click
    source


    This is how I always did it before and is trying to do it now.

    What happens now is I hold block using right mouse button, then press left mouse button to interrupt. This triggers a light attack. Attempting this a couple of times causes me to stop blocking even though I am still pressing down the right mouse button. I have to release it then re-press it to start blocking again. Interrupting with a key bind (currently mapped to V) while blocking works as intended and does not "break" block.
    What mouse are you using?
  • spesimen
    spesimen
    Logitech MX518
  • Moonraker
    Moonraker
    ✭✭✭✭
    spesimen wrote: »
    Logitech MX518
    Do you use the Logitech software for the mouse? I don;t use that as I find it flaky over the years and use another app called Steermouse but not sure if that would cause this issue. I can't reproduce it on my Mac and Logitech G700s.
  • spesimen
    spesimen
    I never used to but I am currently using logitech software currently to be able to map buttons that broke a few patches back.
    I could attempt another with another mouse. Never occurred to me the mouse might be the cause as I have been using this model for the last 4-5 years.
  • Moonraker
    Moonraker
    ✭✭✭✭
    spesimen wrote: »
    I never used to but I am currently using logitech software currently to be able to map buttons that broke a few patches back.
    I could attempt another with another mouse. Never occurred to me the mouse might be the cause as I have been using this model for the last 4-5 years.
    Worth trying another mouse to check. Possibly reset keybindings in game and remap (checking that bindings are default and not changed for some reason) Keybinding is server side so trashing preferences I don't think would help.

  • Seedier
    Seedier
    ✭✭
    (aside: just putting the open apple key in for old times sake, I was sad when it changed to ⌘ )

    couldn't agree more ;)
    Edited by Seedier on July 27, 2014 8:31AM
Sign In or Register to comment.