Maintenance for the week of June 24:
• [COMPLETE] ESO Store and Account System for maintenance – June 26, 4:00AM EDT (08:00 UTC) – 12:00PM EDT (16:00 UTC)

Azura's Relics is bugged

  • raglau
    Hmm, support told me there is going to be a fix for this but until then to try multiple locations in the area to make it spawn. I did this, with another player actually, but the Daedra did not spawn.

    This is irrevocably broken at the moment from what I can see.
  • Crimsonorion
    Still Broke as of September 13th, Scrolls appears in your hand for a second, and your character is frozen in place for a couple seconds but no spawn
  • Diamir
    Soul Shriven
    14th of September, still broken
  • xChewtoyx
    It won't be fixed until 1.4 drops
  • Nogg
    Just finished Azura's Relics. Used scroll and summoned the spider daedra. It only appeared for about 5 seconds though before despawning. Was able to summon it again and then quickly killed it to get the update to the quest.
  • raglau
    This now works for me, with patch 1.4.x
  • Kangas
    Patch 1.4.x worked
    But... Spider daedra summoned with scroll disappeared 3 times before I relogged and then summoned it and killed it as fast as I possibly could.
  • Nogg
    Kangas wrote: »
    Patch 1.4.x worked
    But... Spider daedra summoned with scroll disappeared 3 times before I relogged and then summoned it and killed it as fast as I possibly could.

    I guess if people can't kill it within 5 or 6 seconds by themselves they would need to bring a friend for the next time they try it. At least we are getting past that 1rst spawning issue now.
  • LordLuciendar
    The spider daedra (Vaermina's Webspinner) appears to despawn because the minion spider daedra (the little one that has a shield around it) is killed. Avoid AoE damage and make sure the little daedra isn't targeted and you'll have no issue killing the big one.
  • Aelthwyn
    I had trouble with this as well. I tried numerous times to use the scroll to reveal it but half the time it would only partly play the effect and the daedra would never appear. Then the times that it did appear it would just despawn when it's health was low before I could kill it. I'm not even sure how many times I tried this..... I finally succeeded in killing it swiftly enough that I got it before it despawned. It was reeeeally annoying. The time it worked I did focus my attack on the big one and ignored the little one.
    Edited by Aelthwyn on September 19, 2015 7:05PM
  • Cernow
    STILL bugged.

    Look at the dates on all these posts and reports.

    Embarrassed ZOS? Well you should be.
  • StarWhispers
    I sat there for about twenty minutes watching other people try then give up and delete the mission... You would think they works have fixed this year's ago.. But instead they rather do 10,000 nerfs sorry I mean "adustments".. I am just going to sit there and tell everyone who comes up to attempt to complete this mission to spam the ingame support. Who knows after a few hundred ingame reports they might attempt to fix it yet again. :|
  • Emothic
    Wow, this quest is still bugged. I don't think the developers even care about this quest. This is so annoying.
    Lord Emothic Von Hellsing of ze Hellsing Family.
    Dragon Knight of the Ebonheart Pact. Xbox One - NA
  • ZOS_RyanM
    We have moved this thread to the bug report section of our forums. This is a relatively new section of the forum that was created for the purpose of centralizing this type of issue. As players are still reporting this as an issue we felt it was appropriate to move the thread over here. Feel free to add any additional information you have to this thread.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
  • Sou_rou
    I completed the quest today. Note the following points.

    I had to be standing close to the waterfall to get the "Use the Scroll" prompt. The area that shows you in the zone is apparently too big.

    Once got to the right area, I had to use the scroll several times. Be looking toward the waterfall.

    The spider spawned and I killed it, but it was a fast kill. (I'd been saving the spider a meteor.)

    It's easy to win forgiveness for being wrong; being right is what gets you into real trouble -- Bjarne Stroustrup

  • ScorpioSymbol
    FFS...2017 and this is STILL bugged in the same way.

    Spider despawns within seconds of spawning.
Sign In or Register to comment.