Maintenance for the week of May 29:
• PC/Mac: No maintenance – May 29

Xbox Recording on ESO sometimes does not work

Anyone who plays ESO on xbox, have you ever tried recording a clip or screenshot for it to say "Capturing is Disabled, Sorry, this game doesn't allow capturing"

I have tried numerous attempts to solve this issue/bug. Many others have this issue. Anyone else know why this is just ESO specific? And know how to fix it ?
Edited by ZOS_Kraken on 15 March 2023 19:48
  • ZOS_Kraken

    After further review we have decided to move this thread to a category we think is more appropriate for this topic.

    Thank you for your understanding.
    Staff Post
  • OBJnoob
    No, this hasn't happened to me. Been playing for 5+ years I think and frequently record things to show my wife or even show other people from time to time.

    Only times I can't record are when I've filled my Xbox and need to delete old ones.

    To be fair, it IS possible this has happened to me once and I disregarded/forgot. But I would only have forgotten if the problem had later solved itself. So my question to you is... When did it start? And how long has it been going on for you?
Sign In or Register to comment.