The Firesong DLC and Update 36 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of September 26:
• PC/Mac: No maintenance – September 26

Mouse sensitivity going nuts.

ofenergy
ofenergy
Soul Shriven
I'm a new ESO player, and I'm loving the game so far, only a few hours in. The only thing that's holding me from playing this game more is the mouse sensitivity wackiness.
Every 10 seconds or so my mouse sensitivity will spike for a second or two, making me lose control of everything. I've read things on the internet of disabling display scaling on high DPI settings, but that didn't do anything.

I have a Razer Naga Chroma, and I'm on the latest drivers.

This is kind of a game breaker for me. Any help would be appreciated.
  • Fyaal
    Fyaal
    ✭✭✭
    Same issue. It goes in and out though. Never seen it happen every 10 seconds.
    Fyaal - EP Stam DK Grand Overlord
    Invictus
    Nexus Haxus
    Hijinx
    IR
  • FleetwoodSmack
    FleetwoodSmack
    ✭✭✭✭✭
    Are you guys running Steam? If so, open your Task Manager and end the RazerInGame(I forget the rest of the string).exe task and swap back to the game and it should return to normal. It has a conflict with the Steam Overlay. Now if you're not running Steam, it could also conflict with other things that overlay in the game, buuuuuut it's hard to say. Worth a shot though!
    Tell me lies, tell me sweet little lies!
  • Turdferguson2
    Turdferguson2
    Soul Shriven
    Hmm I wonder if this is my issue as well. I also use a Razer Naga Chroma but whats weird is I never had this problem before up until this latest patch. Now my cursor continues to move after I looked in a certain direction. I'll have to try this though.
  • Mark3DMan
    Mark3DMan
    Soul Shriven
    I know this is an old post but I bumped up to this and found a solution on my system. Problem for me was too high polling rate on my mouse. I use SteelSeries Rival 310 and default polling rate is 1000. I made a profile for ESO that has the polling rate set to 250. No more camera clipping for me.

    Others have found solutions by switching between fullscreen and windowed fullscreen. Adaptive sync/vsync has also been a problem for some. Hope some of these tips helps someone. I have had this polling rate problem in other games aswell like Divinity Original Sin 2.
  • Synoke
    Synoke
    Mark3DMan wrote: »
    I know this is an old post but I bumped up to this and found a solution on my system. Problem for me was too high polling rate on my mouse. I use SteelSeries Rival 310 and default polling rate is 1000. I made a profile for ESO that has the polling rate set to 250. No more camera clipping for me.

    Others have found solutions by switching between fullscreen and windowed fullscreen. Adaptive sync/vsync has also been a problem for some. Hope some of these tips helps someone. I have had this polling rate problem in other games aswell like Divinity Original Sin 2.

    This fixed it for me. I have the HyperX Dart wireless mouse and I had to make an ESO profile just for it to work properly. I also put the game into Fast Vsync under Nvidia settings just to be safe. I appreciate you!
  • ZOS_Bill
    ZOS_Bill
    admin
    As this discussion is over three years old with some outdated information, we've decided to close the thread going forward.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
This discussion has been closed.