Maintenance for the week of August 19:
• PC/Mac: NA and EU megaservers for patch maintenance – August 19, 4:00AM EDT (8:00 UTC) - 8:00AM EDT (12:00 UTC)

ESO and MacOS Catalina

Carmina
Carmina
✭✭✭
Well, aren't we getting used to ZOS being totally incompetent regarding the Mac client? I guess we are.

- Spinning toon
- Crashes
- Performance Issues
- Premature forced upgrades of the graphics engine
- Beta testing by public

Let's add a new thing. Since MacOS Mojave's release, the Launcher was not really compatible with the Mac anymore. The reason being, it is a 32 bit application and not optimised for MacOS. There was a warning popup, but no one at ZOS has cared.

Fast forward to today. We can not run Catalina with ESO. Or the other way round. The Launcher will not start under Catalina, meaning I can still manually launch the game, but once there is an update, this will not work anymore.

So, the question is: When will ZOS be upgrading the client and support Catalina?

I am so getting sick of this ***. The support for the Mac client does not get better over time. It gets worse.

C.
  • Gattopardo
    Well to be fair, wouldn't have made that much sense in the last weeks to update the client as it was clear that the Catalin beta would be out in June. They still have to fix everything, but now they can do it on the actual beta and the changes that come with it.
    If you installed Catalina and expected the launcher to work while it hasn't been updated yet, that one is kind of on you. It's the first developer beta, the official release is not before autumn, some people in the Mac forum seemingly don't even try to be reasonable (not just you).

    The client and launcher is still working like a joke, even compared to the bad windows client, not going to argue with that.
  • Carmina
    Carmina
    ✭✭✭
    @Gattopardo

    Actually, that is only half the truth.

    Apple has announced that OpenGL would be deprecated in 10.15. We are not talking not working anymore. In contrast to this, it was made clear by Apple that 32 bit apps would not work anymore in 10.15. To be fair, it has been announced for literally years that this would happen, and in iOS it has happened a while ago.

    Now, ZOS has moved to upgrade the game itself (OK, the graphics engine it runs on) to Metal2 (actually Vulkan) months ago, not really tested anything, and then started fixing bugs while people were forced to use the game.

    Regarding the launcher though, simply nothing was done. I did not install Catalina, because I knew it would not run, and because Catalina install is warning users. Still, the issue remains the same. ZOS is not interested in the Mac client, unless there really is a ***, as there was with the Vulkan problem. Even then, their reaction is more like a sleeping pill.

    We will see how long ZOS will need to upgrade their Launcher in the end. I am not arguing with the fact that whoever installs a Beta does so on their own risk and should be well informed before doing it. What I am saying is that compared to other developers, who have upgraded their apps to 64 bit a long time ago, ZOS is lacking. I am also saying that I am very sceptical about a company who treats their users like this.

    C.
    Edited by Carmina on June 4, 2019 2:20PM
  • Gattopardo
    Carmina wrote: »
    Fast forward to today. We can not run Catalina with ESO. Or the other way round. The Launcher will not start under Catalina, meaning I can still manually launch the game, but once there is an update, this will not work anymore.
    Carmina wrote: »
    I did not install Catalina, because I knew it would not run, and because Catalina install is warning users.
    You are contradicting yourself here. Seems like you just want to be angry for being angry. Did you expect an eso update for the first developer beta of 10.15?

    Why would a company spend money a year in advance to program a launcher for Catalina, when the current version for Mojave still works and they can't predict what actually will change in 10.15 beforehand, they know it will be coming, but they don't know what will actually happen.
    And are you really surprised by ZOS/Bethesda releasing the Molten-updated client without much testing? Have you played this game at all, a game which more or less breaks with every update and even new content is bugged?

    It's no wonder the staff mostly ignores this forum if the only thing people post is irrelevant screaming without much merit.
    Will they update the client? probably. Will it be buggy and not work as it should be? definitely. Will we be surprised? nope.
  • Carmina
    Carmina
    ✭✭✭
    @Gattopardo

    Dude, seems like you are writing for the sake of it.

    Yes, I expected an upgrade, actually like the major companies way earlier than for the first Beta. And it seems like you have no idea what you are talking about. A 64 bit LAUNCHER is actually a really minor adjustment. Being confronted with an error message pretty much every time you start the game is annoying, and it is symptomatic for the way ZOS is looking at the Mac client. If you want to ramble about me being disappointed, go ahead. It will not change it.

    It was clear for over a year that 32 bit apps would not be supported anymore. For all the time since Mojave, there is an error message when starting the client, nothing happened. Same thing with the spinning toon, the frame rate, the windowed mode.... I do not get why you defend ZOS' actions, but if you want to do that, be my guest.

    Again, lose your stance, I am not angry because I want to be angry. I am pissed because I am looking at a client that was a catastrophe from the get go, and just got worse, and I am using this as an opportunity to point out how poorly ZOS is looking that the Mac. That's it. If you are not happy with that stance of mine, I am sorry, but that is how it is, and actually this will be my last answer to your stupid accusations :)

    Understand the technical side, see what I am talking about, understand the words, and try to be helpful. Stop attacking posters.

    C.

    P.S. I am not contradicting myself. I said the launcher will not run (I know that because it is a 32 bit app, duh), and I did not install it. So where is the contradiction? I think you need to work on your rhetorics. Scratch that, you need to work on your understanding of technical things :)
    Edited by Carmina on June 4, 2019 3:07PM
  • Gattopardo
    Collection of Poetry, seems like you are getting the point. I'm answering you in really useless terms, because that seems to be all you are actually doing in this forum, as you post these threads quite regularly to no new point whatsoever. Not "attacking" you, just being as annoying and pointless as you.

    support can delete this thread now, we made it even more pointless than it actually was from the beginning <3
    Edited by Gattopardo on June 4, 2019 3:20PM
  • ZOS_BillE
    ZOS_BillE
    admin
    As this thread has become unconstructive we will be closing the discussion. You are welcome to discuss future OS releases in relation to ESO, but the discussion must be kept civil.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
This discussion has been closed.