Maintenance for the week of January 27:
• PC/Mac: NA and EU megaservers for patch maintenance – January 27, 4:00AM EST (9:00 UTC) - 8:00AM EST (13:00 UTC)
• ESO Website for maintenance – January 27, 1:00PM EST (18:00 UTC) - 4:00PM EST (21:00 UTC)

Direct x and SPINF.dll errors.

Hello, I recently tried to download end user web from Microsoft so fix my problem with pressing play on the launcher, it came up with the error of "d3dxd9_43.dll". However when I tried to download the end user web to fix this it came up with an error saying "C:\\windows\system32\SPInf.dll is not compatible" or something along them lines. please help!
  • Ardatlile
    Hey, did you fix your problem? I'm sitting with the exact same problem on my laptop. Tried a program that fixes .dll files, updating drivers, run a complete malware scan and so on. Can't seem to get a definitive answer on the interwebs either to what might solve this problem..
  • Sihnfahl
    Okay, first, what's your OS and which video card are you using?
  • ZOS_ChesterN
    Hail Defilers of Molag Bal!

    The "Error initializing D3D9 device: Shader Model 3.0 is required." is mainly due to your Direct X being corrupt or not installed properly.

    Here is a link with instructions on how to download it:

    What we can also try to resolve this specific issue is to have you delete the ShaderCache.cooked file which can be found in the game documents folder. The default location for the file is C:\Users\*USERNAME*\My Documents\Elder Scrolls Online\live. After that file is deleted, run the game as administrator, and it will recompile that file.
Sign In or Register to comment.