The Firesong DLC and Update 36 base game patch are now available to test on the PTS! You can read the latest patch notes here: https://forums.elderscrollsonline.com/en/categories/pts
Maintenance for the week of September 26:
• PC/Mac: No maintenance – September 26

Launcher scaling

o0madness0ob14a_ESO
o0madness0ob14a_ESO
Soul Shriven
Hey, is there any way to increase the size of the launcher itself? I recently upgraded to a 4k display and the launcher is now literally 4" by 6" on the screen, way too small to get any relevent information. The in-game scaling works amazingly well btw, much better than many (very many) other games that offer 4k res.
  • karmamule
    karmamule
    ✭✭✭
    I know this is an old thread but thought I'd add my "me too" here. I now play on a 4k display, and the game itself scales and looks wonderful, but the launcher doesn't do the same and it's almost impossible to read any text on it other than the PLAY button or the major links along the top.
  • ZOS_GaryA
    ZOS_GaryA
    ✭✭✭✭✭
    Hey there @karmamule,

    Currently there is not a way to scale the launcher, though we're glad to hear this feedback! We'll definitely be sure to pass this along.

    One workaround would be to use the Magnifier application that is installed with Windows. To use this, simply click Start, type Magnifier in the search box, and run the program. This can help you read any errors that may occur during patching.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Facebook | Twitter | Google+ | Tumblr | Pinterest | YouTube | ESO Knowledge Base
    Staff Post
  • karmamule
    karmamule
    ✭✭✭
    Thanks For the reminder on that feature Gary, I'll use that for now! :)
  • Smaxx
    Smaxx
    ✭✭✭✭✭
    As an addition, you don't even have to use the Start menu for that. Just hit Win + Plus (on the Numpad) and the magnifier app launches.
  • michperr1b14_ESO
    michperr1b14_ESO
    Soul Shriven
    ZOS_GaryA wrote: »
    Hey there @karmamule,

    Currently there is not a way to scale the launcher, though we're glad to hear this feedback! We'll definitely be sure to pass this along.

    One workaround would be to use the Magnifier application that is installed with Windows. To use this, simply click Start, type Magnifier in the search box, and run the program. This can help you read any errors that may occur during patching.

    I know this is an old thread, but it's been 10 months...any updates?
  • hfm
    hfm
    Soul Shriven
    Hard to believe the launcher still doesn't scale properly for HiDPI displays. It would be nice if a 2X magnification option at least existed.
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    After taking about a year off, I have decided to check out ESO again and see what has improved and test the upcoming Update 12 in PTS. I was surprised to see that they still have not fixed the DPI issue with 4K displays.

    Fortunately I previously found a good work around at this site: http://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/

    It is talking about Adobe of course, but this works on the ESO launcher as well as many other programs that don't properly scale. I cannot remember if it is in that linked site but if not you can Google to find out how to extract the manifest to alter it to tell the application that it is not High DPI aware. Also make sure you do the registry edit to allow Windows to prefer external manifests.

    Sadly I would think it would not be hard for the developers to at least update the manifest to flag the app as not high DPI aware until they get around to properly supporting high dpi displays. It cannot be that hard.

    @ZOS_GaryA could you put this request in to the developers?

    EDIT: Here is the contents for the file which should be named Bethesda.net_Launcher.exe.manifest and placed in the same folder as the launcher. I just tested and it still works.
    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
      <dependency>
          <dependentAssembly>
              <assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.0.0" processorArchitecture="x86" publicKeyToken="6595b64144ccf1df" language="*"></assemblyIdentity>
          </dependentAssembly>
      </dependency>
      <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
        <security>
          <requestedPrivileges>
            <requestedExecutionLevel level="asInvoker" uiAccess="false"></requestedExecutionLevel>
          </requestedPrivileges>
        </security>
      </trustInfo>
      <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">  
        <application>
            
            <supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"></supportedOS>
            
            <supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"></supportedOS>
            
            <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"></supportedOS>
            
            <supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"></supportedOS>
        </application>
      </compatibility>
      <asmv3:application xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
        <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
          <dpiAware>false</dpiAware>
        </asmv3:windowsSettings>
      </asmv3:application>
    </assembly>
    
    Edited by JasonSilverSpring on September 18, 2016 3:06PM
  • Zaindari
    Zaindari
    ✭✭
    I cant believe this hasn't been fixed I mean really you guys have made a great game but cant fix such simple little problems.
  • AstroGazer1
    Thsnks, I will try this.
  • AstroGazer1
    Did not work for me. But then again, I might of not installed it right.
  • AstroGazer1
    JasonSilverSpring = Never Mind. This works - had to add line in reg edit as described above in link. Many Thanks.
  • Ulfson
    Ulfson
    ✭✭✭
    So here in September of 2017 I can not play with my 4k laptop due to this scaling issue. It did work two months ago by changing the file properties for the eso64.exe such that Properties / Compatibility
    Override high DPI scaling behavior... System (Enhanced)

    Now nothing works. I tired Jasonsilversprings fix but got lost tying to figure out how to make the registry changes and other inferred changes. Too hard.

    Anyone know of a fix that is not so elaborate? One like click on Play?
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    Ulfson wrote: »
    So here in September of 2017 I can not play with my 4k laptop due to this scaling issue. It did work two months ago by changing the file properties for the eso64.exe such that Properties / Compatibility
    Override high DPI scaling behavior... System (Enhanced)

    Now nothing works. I tired Jasonsilversprings fix but got lost tying to figure out how to make the registry changes and other inferred changes. Too hard.

    Anyone know of a fix that is not so elaborate? One like click on Play?

    With each Windows major update you have to redo the registry change unfortunately.

    The only other option is to use the built in Windows magnifier. Press and hold Windows key and then press +. Then the entire screen will enlarge as you mouse over it.

    Actually there is another option I just thought of. Create a shortcut to the eso64.exe file and bypass the launcher. But you will still need to use launcher when patching the game.
  • Ulfson
    Ulfson
    ✭✭✭
    Jason, Thanks for the reply.
    I was headed toward your latest suggestions and decided to just try a simple reinstall.
    Well I never made any registry changes (too lazy really) but the game will play from the launch window.
    I didn't change the compatibility settings.
    It's a mystery but I wonder if ZOS fixed the high res startup issues?

    FYI, I am using a Surface Pro (5) i7 16GB with 2736x1824 screen.
    It runs at 25-45fps and is good enough for most non-pvp or trials stuff.
    Happy Trails
  • Ulfson
    Ulfson
    ✭✭✭
    Update on the screen scaling.
    I have had the exe64.exe start about 4/5 times with the full screen. Randomly it will start in the postage stamp size in the upper right. But it is still not really playable. The user interface is scaled independent from the game graphics. So my chat and HUD messages are teeny tiny minuscule patches on the screen.
    Looking for ways to scale the UI but so far no success.

    Happy Trails
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    There is an in game setting to adjust the UI scale. That should help. I am not at my computer now to look it up.

    If you are not playing the game at native resolution I recommend setting the Windows resolution to match the game resolution to avoid UI issues.
  • Universe
    Universe
    ✭✭✭✭✭
    ✭✭
    I had the same issue since I started playing on 4K.
    I have recently found a solution on my own when I changed the different settings.
    You need to do the following:
    1. Right click on the file named "Bethesda.net_Launcher"(this file can usually be found at "Program Files (x86)\Zenimax Online\Launcher".
    2. Click "Properties".
    3. Click "compatibility".
    4. Click "change high DPI settings".
    5. Click "Override high DPI scaling behavior" and change it to "System".
    6. Click "OK".
    7. Click "Apply" and then "OK".

    You are now able to display the launcher in a huge window without any issues :)
    @ZOS_RobGarrett @ZOS_GinaBruno Maybe you can add this solution to the Support portal, so others can enjoy it too :)
    Maybe it's not the best solution but it definitely works.
    Edited by Universe on September 14, 2018 5:59PM
    Some videos I recorded for fun: Main character:
    PC EU main: Universe - AD magicka Sorcerer, Former Emperor, Grand Overlord, The Merciless, Trial Bosses Solo Champion
    Top alts: Genius(stamina/sagicka Dragonknight) The Force(stamina Nightblade) and other chars.
    PC NA main: The Magic - AD magicka Sorcerer
    Started playing ESO in beta & early access
    User_ID: Daedric_Prince
  • JasonSilverSpring
    JasonSilverSpring
    ✭✭✭✭✭
    Universe wrote: »
    I had the same issue since I started playing on 4K.
    I have recently found a solution on my own when I changed the different settings.
    You need to do the following:
    1. Right click on the file named "Bethesda.net_Launcher"(this file can usually be found at "Program Files (x86)\Zenimax Online\Launcher".
    2. Click "Properties".
    3. Click "compatibility".
    4. Click "change high DPI settings".
    5. Click "Override high DPI scaling behavior" and change it to "System".
    6. Click "OK".
    7. Click "Apply" and then "OK".

    You are now able to display the launcher in a huge window without any issues :)
    @ZOS_RobGarrett @ZOS_GinaBruno Maybe you can add this solution to the Support portal, so others can enjoy it too :)
    Maybe it's not the best solutions but it definitely works.

    Yeah, Microsoft finally added the option to override. The easier solution is for ZOS to set the manifest to tell windows that the launcher is not high DPI aware. Or, better, make it actually be high DPI aware.
  • qbit
    qbit
    ✭✭✭✭✭
    Universe wrote: »
    I had the same issue since I started playing on 4K.
    I have recently found a solution on my own when I changed the different settings.
    You need to do the following:
    1. Right click on the file named "Bethesda.net_Launcher"(this file can usually be found at "Program Files (x86)\Zenimax Online\Launcher".
    2. Click "Properties".
    3. Click "compatibility".
    4. Click "change high DPI settings".
    5. Click "Override high DPI scaling behavior" and change it to "System".
    6. Click "OK".
    7. Click "Apply" and then "OK".

    You are now able to display the launcher in a huge window without any issues :)
    @ZOS_RobGarrett @ZOS_GinaBruno Maybe you can add this solution to the Support portal, so others can enjoy it too :)
    Maybe it's not the best solutions but it definitely works.

    Yeah, Microsoft finally added the option to override. The easier solution is for ZOS to set the manifest to tell windows that the launcher is not high DPI aware. Or, better, make it actually be high DPI aware.

    Well this would require reading API docs and understanding them. Do you realize what you are suggesting, sir?

    Look, I get it, you want to make your launcher one giant image like image maps of HTML 3. That’s fine. A junior intern programmer could have suggested changes to the xml of the manifest file to let windows scale that entire thing automatically. But I guess we still use the visual studio template manifest in the project. Or “solution” or whatever nonsense they decide to call it these days.
    Edited by qbit on September 14, 2018 6:24PM
  • hfm
    hfm
    Soul Shriven
    How is this still not fixed. HiDPI displays are becoming commonplace, can you guys please make this launcher compliant with HiDPI displays.
  • SCarverOrne
    SCarverOrne
    ✭✭
    I too have a 4k display, and the launcher is tiny. Has this still not been addressed, in 2019?
  • ZOS_Bill
    ZOS_Bill
    admin
    As this thread is nearly 5 years old we are closing the discussion. You are welcome to start a new thread with suggestions and feedback related to launcher scaling if no recent threads are ongoing.
    The Elder Scrolls Online: Tamriel Unlimited - ZeniMax Online Studios
    Forum Rules | Code of Conduct | Terms of Service | Home Page | Help Site
    Staff Post
This discussion has been closed.