Maintenance for the week of February 18:
• [COMPLETE] Xbox One: EU megaserver for maintenance – February 20, 4:00AM EST (9:00 UTC) - 12:00PM EST (17:00 UTC)
The Wrathstone DLC Game Pack and Update 21 base game patch are now available to test on the PTS! Read the full patch notes here: https://forums.elderscrollsonline.com/en/discussion/454456/

Hozzin's Folly Door Doesn't Like Me

Obsydiandragon
I have been back and forth with the ESO help desk, but all the suggestions they've given me haven't worked. I've tried relogging my character, resetting the interface, abandoning and reacquiring the quest over a dozen times and even joining a group. Said group friend was able to get through the door JUST FINE, but it still would not let me enter. I have completed the quest multiple times before with zero issues on other characters, so I do not know what the issue is this time. I have seen many other players go through the door, but it just doesn't like me, I guess?

I would like a fix on this asap as it is all I need left to complete Bleakrock Isle. I cannot DO anything else unless I skip it and fairly certain I cannot then go back and get Sayne/finish the quest later?
Sign In or Register to comment.