The issues related to logging in to the European PC/Mac megaserver have been resolved at this time. If you continue to experience difficulties at login, please restart your client. Thank you for your patience!
Maintenance for the week of April 19:
• [COMPLETE] Xbox One: NA and EU megaservers for patch maintenance – April 21, 6:00AM EDT (10:00 UTC) - 10:00AM EDT (14:00 UTC)
• [COMPLETE] PlayStation®4: NA and EU megaservers for patch maintenance – April 21, 6:00AM EDT (10:00 UTC) - 10:00AM EDT (14:00 UTC)
The Blackwood Chapter and Update 30 are now available for testing on the PTS! Read the full patch notes here:

Solution for kicks

I need to post this because this was happening on another title I was fond of and they solved it with a simple fix.

If a character is kicked or is booted offline without clicking the logout screen they made their launcher automatically log that player back in without placing that player in the queue so there was no wait time for that player. If there was an overload of players who've not logged in yet were to try to login during this period the server would automatically put the booted person back at the front of the line when booted.

I'd suggest this be considered during the fixing process because this made a world of difference in that other game this happened on.
  • nik8771
    Soul Shriven
    I keep getting kicked after about fifteen minutes of play. It's really irritating. I'm probably just gonna play witcher for a week and see if this is just a temporary thing. I've never had issues with internet connection on any other games so I don't think it's that.
  • Elements001
    I have also been getting kicked after 15 minutes or less with the "failed to connect to server. Please make sure you have a valid internet connection" message. I have never had any issues like this with aby other games.

    I ran a speed test and it came back at 60mbps download, 5.7 Mbps upload and 11ms latency. I have my Xbox one connected to the internet via Ethernet cable and there is literally nothing else using the internet in my residency when I'm playing.

    I'd just like to know if there's anything I can do, or if it's all on their end and I'll just have to patiently wait.
  • nik8771
    Soul Shriven
    I don't even get an error. I just get kicked chuck Norris style back to home screen and have to load the game from start again.
  • icurehangovers
    @nik8771 That's not a kick. That's the game crashing. Getting kicked means a server error. Your game crashing means there was a software/hardware error on your (client) side.

    @Elements001 What does your nat type look like? Look for it in the network settings where you ran your speed tests. In the middle section where you have Current Network Status, just under where it says wired, there is a NAT Type:______. What does it say there? If you have anything other than open, that might be your issue. You need an Open Nat to play with anyone else. If you are on a Moderate, you can only play with those who have a Moderate or higher NAT. If you have a Strict, you are restricted to only those with a strict. This causes issues with MMOs because you have people with all sorts of different NAT types.

    Sometimes NAT is an issue with your router. I found this article from PC World. It's old but still relevant, I think. If your issue is coming from your modem or ISP then you're pretty much screwed. You should contact you ISP and cross your fingers. If your router is supplied by your ISP (a modem that acts as a router/wifi) you will also most likely have to contact your ISP as well as they sometimes lock customers out so they won't mess with the settings. If you have your own router, make sure your modem is set to bridge mode and not anything else.

    That's all I can think of. Good luck.

    P.S. This theory is all based on several threads about the disconnections I have seen. Most people getting kicked constantly either don't seem to have an open NAT or don't seem to know what a NAT is. If neither of these apply to you, then maybe Nirn or the Nine Divines hate you. I don't know lol.
    Edited by icurehangovers on June 12, 2015 11:07PM
  • Elements001
    I appreciate the response, however I do have an open Nat. I she run the network test several times and everu time I go to settings it has said open. I've never seen it say anything other than open, which is why I'm so confused. I've played several mmo games and have never had this issue with any other than ESO.
Sign In or Register to comment.