Maintenance for the week of January 17:
• [COMPLETE] PlayStation®: NA megaserver for maintenance – January 19, 2:00AM EST (7:00 UTC) – 12:00PM EST (17:00 UTC)
• [COMPLETE] Xbox: NA and EU megaservers for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• [COMPLETE] PlayStation®: EU megaserver for maintenance – January 19, 6:00AM EST (11:00 UTC) – 10:00AM EST (15:00 UTC)
• ESO Store and Account System for maintenance – January 20, 8:00AM EST (13:00 UTC) – 3:00PM EST (20:00 UTC)

Azura's Relics is bugged

Azura's Relics in Stormhaven is bugged. After spawning the daedra it just disappears after 20-30 sec of combat.
  • mssteffie
    I couldn't finished it either.
  • jy82988ub17_ESO
    Just finished it, but had to have 4-5 people there to burn him down before he disappears.
  • omegadragon_1b16_ESO
    Soul Shriven
    Am having the same issue.
  • p_tsakirisb16_ESO
    I can confirm as of 1.2.3 version the same bug still exists. At VR7 instanced area.
  • voltorsfury
    Just wanted to report that as of today, this quest worked well for me, just had the scamp out with me and killed the spider fine.
    @Voltorsfury - GM of Order Of Explorers PvE/PvX guild - Ebonheart Pact
    Mid Sized, Friendly, Active, semi-casual guild! We use TS 3 for events.
  • Eims
    Soul Shriven
    i have still the same problem... the deadra disappears after 10-15 seconds. no chance to hit him down fast enough and no chance to find some people to help... -.-
  • dan0311
    Can't even get the daedra spider to appear. I click "use the scroll of sight" and it just moves the POV a tiny bit for a fraction of a second, then I have to wait until I can use the scroll again. Rinse, repeat. Come ON, ZOS...hasnt this damn game been out since APRIL? Its almost September....why are things still broken?
  • KiriX
    Confirm... Still bugged =(
    PC EU
  • xdrdrummermanxb14_ESO
    I said bump and it got removed, so ill say Confirm...Still Bugged :(
  • Carraig
    Completed it last weekend without problems. But maybe I was lucky for a change.
    Brother of The Black (CP750+ Daggerfall Covenant-EU server-PC)
    Scath Idhrenohtar - Dunmer Nightblade - Colonel in the Daggerfall Covenant
    Arturia Castus - Imperial Templar - Captain in the Daggerfall Covenant
    Constance Dewintre - Breton Sorcerer - Sergeant in the Daggerfall Covenant
    Caira Aqsoric - Breton Nightblade - Recruit in the Daggerfall Covenant

    "Courage is not the absence of fear, but rather the judgment that something is more important than fear. The brave may not live forever, but the cautious do not live at all."
  • voldemortlol
    Soul Shriven
    nothing spawning
  • Resueht
    Scroll causes me to glow and then nothing happens for me. I submitted /bug as well.
    Edited by Resueht on August 28, 2014 7:16PM
    If she doesn't know the pain of cliffracers, she's too young for you.
  • draquius
    Soul Shriven
    Same issue, I glow red for 1 sec then nothing. Have tried with and without the scamp.
  • stumpy999
    same here, a red glow, my character locks up and is unable to move or cast for a few secs then nothing
  • Royalty27
    I'm unable to complete this quest. I use the scroll and nothing happens other than not been able to move for a few seconds
  • raglau
    Can't make Daedra spawn either. Looks like it's broken for about 10 people, all stood about trying to spawn the monster.
  • reften
    broken, can't spawn the daedra, and there is no map indicator on where to go for the quest
    Bosmer (Wood Elf)
    Moonlight Crew (RIP), Misfitz (RIP), Victorem Guild

    VR16 NB, Stam build, Max all crafts.

    Azuras & Trueflame. Mostly PvP, No alts.

    Semi-retired till the lag is fixed.

    Love the Packers, Bourbon, and of those will eventually kill me.
  • Seravi
    Yeah a bunch of us standing here and it won't spawn in Vet level. Logged out, waited a bit and went back in. Still nothing...
  • Alphashado
    LOVE how new posts about this bug are getting closed by mods and getting redirected to this thread..... that is 3 MONTHS OLD. And on the DC forum no less. Way to absolutely bury a "known issue".
    Edited by Alphashado on August 30, 2014 8:43PM
  • thor222999_ESO
    Are we just gonna get re-directed, but they are not gonna fix anything? If Mod or Game master even alive?
  • sm00nieb16_ESO
    Soul Shriven
    Been trying this a few times today. But I'm experiencing the same issue as a lot here: I'll glow red and then no spawns appear. I submitted a bug report as well.
  • Resueht
    I had posted on the assistance forum a couple weeks ago. I am happy to say this quest is explicitly mentioned in the 1.4 notes slated to come out soon. It should be fixed shortly it seems.
    If she doesn't know the pain of cliffracers, she's too young for you.
  • Pseudonym
    Still broken. Won't work for me either or the random stranger next to me.
  • Tanaka_Khan
    Still bugged. Sent a report in.
  • raglau
    ESO support got back to me, said to abandon and restart quest. Has anyone tried that, what happened?
    Edited by raglau on September 8, 2014 11:40AM
  • charley222
    same crap after 6 month quest are still not fix
    the wall of the covenant
  • xChewtoyx
    Pibbles wrote: »
    ESO support got back to me, said to abandon and restart quest. Has anyone tried that, what happened?

    I tried that and it was still bugged

  • StarScythe
    It bugged out for me at the waterfall too as I couldn't summon the daedra. I abandoned it and picked it up again, but it's still broken.
    Edited by StarScythe on September 9, 2014 5:30PM
  • SoupDragon
    Broken for me too! Will try again later...
  • LyonheartCo
    BROKE>> PLEASE FIX THIS! scroll wont spawn mob
Sign In or Register to comment.